samsung: add subtarget condition for device
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 28 Dec 2019 15:08:38 +0000 (16:08 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 2 Jan 2020 23:04:22 +0000 (00:04 +0100)
The only device in samsung target is meant to be built with s5pv210
subtarget. Thus, though this won't make a difference for a
one-subtarget target, already add the condition to the Makefile to
make the assignment obvious.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/samsung/image/Makefile

index 53509ef137f66eff9e7abe0a1f191232a6844c55..36485627046396cc565fd4d70dae46ae69cb7665 100644 (file)
@@ -17,6 +17,8 @@ define Device/Default
   DEVICE_DTS = $$(SOC)_$(1)
 endef
 
+ifeq ($(SUBTARGET),s5pv210)
+
 define Device/embedsky_tq210
   DEVICE_VENDOR := EmbedSky
   DEVICE_MODEL := TQ210
@@ -24,4 +26,6 @@ define Device/embedsky_tq210
 endef
 TARGET_DEVICES += embedsky_tq210
 
+endif
+
 $(eval $(call BuildImage))