build: uImage: allow override of default arguments
authorSander Vanheule <sander@svanheule.net>
Wed, 4 Nov 2020 09:21:13 +0000 (10:21 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 25 Nov 2020 14:46:34 +0000 (15:46 +0100)
For some build recipes, the argument to Build/uImage is used to sneak in
extra arguments for mkimage, whereas this appears to have been intended
to specificy the compression method only.

Use the first provided word for -C to be backwards compatible with
current calls to Build/uImage. Use the rest of the call arguments to
override the provided defaults. Only the input file name (-d) and the
output file name cannot overriden.

Signed-off-by: Sander Vanheule <sander@svanheule.net>
include/image-commands.mk

index 438f1e87e4d267276c2d0c23fdf5711b7dbd0ff1..a8faefbcff6e677fdaac68846ec6d3f22c571941 100644 (file)
@@ -396,8 +396,9 @@ endef
 define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
-               -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
+               -C $(word 1,$(1)) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' \
+               $(wordlist 2,$(words $(1)),$(1)) -d $@ $@.new
        mv $@.new $@
 endef