kernel/modules: make sure igb loads at boot
authorChris Blake <chrisrblake93@gmail.com>
Tue, 15 Jun 2021 13:03:05 +0000 (08:03 -0500)
committerPaul Spooren <mail@aparcar.org>
Mon, 21 Jun 2021 18:38:07 +0000 (08:38 -1000)
Without loading the igb at boot, the recovery wouldn't have
network available. All network drivers should be loaded before
etc/board.d/02_network is called. Note that other network drivers
already have this set, such as tg3.

Fixes: 7e0e5110bc90 ("kernel: add igb kernel module")
Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
package/kernel/linux/modules/netdevices.mk

index 10eb26a7afbefcc335e7d0d12a2e5280afdfd619..b91442748d43de11716071a25d81a12267f28fb6 100644 (file)
@@ -657,7 +657,7 @@ define KernelPackage/igb
     CONFIG_IGB_HWMON=y \
     CONFIG_IGB_DCA=n
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/intel/igb/igb.ko
-  AUTOLOAD:=$(call AutoLoad,35,igb)
+  AUTOLOAD:=$(call AutoLoad,35,igb,1)
 endef
 
 define KernelPackage/igb/description