bcm47xx: relocate LZMA loader #2
authorRafał Miłecki <rafal@milecki.pl>
Tue, 7 Feb 2023 14:06:50 +0000 (15:06 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 24 Feb 2023 11:05:14 +0000 (12:05 +0100)
Increased size of the 5.15 kernel requires bumping BZ_TEXT_START again.
Without this CFE hangs at the:
Starting program at 0x80001000

This fixes booting 5.15 based mips74k images on:
1. BCM4706 (Luxul XWR-1750)
2. BCM5357B0 (Linksys E1000 V2.1)
3. BCM47186B0 (Luxul XWR-600)
4. BCM5358 (Linksys E2500 V3)

It isn't needed but also doesn't break:
1. BCM5354 (Asus WL-500gP V2)

Ref: 4cd97e476089 ("bcm47xx: relocate LZMA loader")
Cc: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/bcm47xx/image/lzma-loader/src/Makefile

index a3e7ae1c92ee0785f1a547ba24673b652cd8a44e..0bad8dd9bb393b1356242732208d93766ca7d281 100644 (file)
@@ -18,8 +18,8 @@
 #
 
 TEXT_START     := 0x80001000
-BZ_TEXT_START  := 0x80700000
-BZ_STACK_START := 0x80800000
+BZ_TEXT_START  := 0x80d00000
+BZ_STACK_START := 0x80e00000
 
 OBJCOPY                := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S