kernel: kmod-rxrpc: add missing dependencies
authorTony Ambardar <itugrok@yahoo.com>
Sat, 27 May 2023 06:22:56 +0000 (23:22 -0700)
committerNick Hainke <vincent@systemli.org>
Sun, 28 May 2023 05:45:50 +0000 (07:45 +0200)
From commit dc0e6056de ("rxrpc: Fix missing dependency on NET_UDP_TUNNEL")
upstream, kmod-rxrpc uses functions enabled by CONFIG_NET_UDP_TUNNEL.

Add package dependencies on kmod-udptunnel4 and kmod-udptunnel6 to avoid
build errors like:

  Package kmod-rxrpc is missing dependencies for the following libraries:
    ip6_udp_tunnel.ko
    udp_tunnel.ko

This change applies to both kernels 5.15 and 6.1.

Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/kernel/linux/modules/netsupport.mk

index dcc2799c79afe5e5ef0fb0a288977ad536f11158..3cbbf6c104d5587f6dbd076119dcfdb866104879 100644 (file)
@@ -1275,7 +1275,8 @@ define KernelPackage/rxrpc
   FILES:= \
        $(LINUX_DIR)/net/rxrpc/rxrpc.ko
   AUTOLOAD:=$(call AutoLoad,30,rxrpc.ko)
-  DEPENDS:= +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt
+  DEPENDS:= +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt \
+    +kmod-udptunnel4 +kmod-udptunnel6
 endef
 
 define KernelPackage/rxrpc/description