wolfssl: change armvirt reference to armsr
authorMathew McBride <matt@traverse.com.au>
Tue, 6 Jun 2023 23:24:18 +0000 (23:24 +0000)
committerPetr Štetiar <ynezz@true.cz>
Tue, 13 Jun 2023 12:14:33 +0000 (14:14 +0200)
armvirt target has been renamed to armsr (Arm SystemReady).

Signed-off-by: Mathew McBride <matt@traverse.com.au>
(cherry picked from commit 203deef82cdcb2c4deb01e2a4cee62a600723320)

package/libs/wolfssl/Makefile

index 260335c34f642ac8e770900a609f0476e38606df..d9426d75fc303d485797e73b604465d9f42633ba 100644 (file)
@@ -100,8 +100,8 @@ This variant uses AES CPU instructions (Intel AESNI or ARMv8 Crypto Extension)
 endef
 
 define Package/libwolfsslcpu-crypto/config
-    if TARGET_armvirt && PACKAGE_libwolfsslcpu-crypto = y
-       comment "You are about to build libwolfsslcpu-crypto into an armvirt_64 image."
+    if TARGET_armsr && PACKAGE_libwolfsslcpu-crypto = y
+       comment "You are about to build libwolfsslcpu-crypto into an armsr_64 image."
        comment "Ensure all of your installation targets support the Crypto Extension. "
        comment "Look for the 'aes' feature in /proc/cpuinfo. This library does not do "
        comment "run-time detection and will crash if the CPU does not support it.     "