linux-atm: use target specific kernel headers
authorMartin Schiller <ms@dev.tdt.de>
Mon, 31 Jul 2023 06:10:23 +0000 (08:10 +0200)
committerMartin Schiller <ms@dev.tdt.de>
Thu, 5 Oct 2023 08:31:39 +0000 (10:31 +0200)
There are a few targets that mess with the atm kernel headers. To avoid
incompatibility between kernel and user space during compilation, the
correct headers should be used.

Consequently, the package must also be marked as nonshared.

Signed-off-by: Martin Schiller <ms@dev.tdt.de>
package/network/utils/linux-atm/Makefile

index c74febcbbc39a3337d354283c596845cb4195952..43f4b6556b5818ccf2ef3fc73cad2fdc0a9bf788 100644 (file)
@@ -21,6 +21,7 @@ PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+
 PKG_CPE_ID:=cpe:/a:linux-atm:linux-atm
 PKG_FIXUP:=autoreconf
+PKG_FLAGS:=nonshared
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -98,6 +99,8 @@ endef
 
 $(foreach t,$(ATM_DEBUG_TOOLS),$(eval $(call GenAtmPlugin,atm-$(t),$(t))))
 
+TARGET_CFLAGS += -I$(LINUX_DIR)/user_headers/include
+
 define Build/Configure
        $(call Build/Configure/Default)
        # prevent autoheader invocation