sysfsutils: Define START early in file
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 26 Sep 2022 08:57:43 +0000 (09:57 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 26 Sep 2022 16:58:32 +0000 (17:58 +0100)
The luci ucode rewrite exposed the definition of START as being over 1K
from start of file.  Initial versions limited the search for START &
STOP to within the 1st 1K of a file.  Whilst the search has been
expanded, it doesn't do any harm to define START early in the file like
all other init scripts seen so far.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/libs/sysfsutils/Makefile
package/libs/sysfsutils/files/sysfsutils

index 8ce9a40f9145ff4584c6979c71c1724941d968ea..ff676308dab5af80d5fb7504bd11f1b904d4f951 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sysfsutils
 PKG_VERSION:=2.1.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-diag
index 0305ca82a9d574547d5fb00e50e4d4ab55e9aedf..3c5b35e78d3dd064c59234698fecbcf7042a92cd 100644 (file)
@@ -4,6 +4,8 @@
 # Based on Debian's script /etc/init.d/sysfsutils by
 # Martin Pitt <mpitt@debian.org>
 
+START=11
+
 load_conffile() {
        FILE="$1"
        sed  's/#.*$//; /^[[:space:]]*$/d;
@@ -39,7 +41,6 @@ load_conffile() {
        }
 }
 
-START=11
 start() {
        for file in /etc/sysfs.conf /etc/sysfs.d/*.conf; do
                [ -r "$file" ] || continue