binutils: Deactivate msgpack
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 8 Mar 2023 22:59:48 +0000 (23:59 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 9 Mar 2023 20:38:17 +0000 (21:38 +0100)
Deactivate the msgpack option. The binutils build might detect the
libmsgpackc.so.2 library and will try to link against it, if it is not
explicitly deactivated.

This prevents the following build errors seen in the build bots.
Package binutils is missing dependencies for the following libraries:
libmsgpackc.so.2

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/devel/binutils/Makefile

index 95939f2dcd94b6568c2eeaeddf0bc212eb3f7aaf..5166f267347f73bfdb6a77404837884298483441 100644 (file)
@@ -90,6 +90,7 @@ CONFIGURE_ARGS += \
        --enable-install-libctf \
        --with-system-zlib \
        --without-zstd \
+       --without-msgpack \
        --disable-gprofng
 
 define Build/Install