build: use ccache -C for cleaning the cache
authorSven Wegener <sven.wegener@stealer.net>
Fri, 1 Jan 2021 10:46:04 +0000 (11:46 +0100)
committerPaul Spooren <mail@aparcar.org>
Thu, 7 Jan 2021 01:31:18 +0000 (15:31 -1000)
This keeps the configuration, like the size of the cache, and the
statistics intact. Move the removal of the cache directory to the
distclean target, but only delete the .ccache directory inside of our
build tree, as we should not mess with a user-configured external ccache
directory this destructively.

Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
Makefile
include/toplevel.mk

index f1577ad4d143b9ece4536e0e8c0551a8484eb5dd..0144b0c5ffc9b99dfd0a280f4b8f3e029f025e8b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -64,7 +64,7 @@ dirclean: clean
 
 cacheclean:
 ifneq ($(CONFIG_CCACHE),)
-       rm -rf $(CCACHE_DIR)
+       $(STAGING_DIR_HOST)/bin/ccache -C
 endif
 
 ifndef DUMP_TARGET_DB
index d3500ef58f098c53f37ceb5394c1d7e84a9243c3..23bae149d4650a9e7cb69fd1754184c0ef9cf5e8 100644 (file)
@@ -261,8 +261,8 @@ package/symlinks-clean:
 help:
        cat README.md
 
-distclean: cacheclean
-       rm -rf bin build_dir .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
+distclean:
+       rm -rf bin build_dir .ccache .config* dl feeds key-build* logs package/feeds package/openwrt-packages staging_dir tmp
        @$(_SINGLE)$(SUBMAKE) -C scripts/config clean
 
 ifeq ($(findstring v,$(DEBUG)),)