build: sort default packages and split by newlines
authorPaul Spooren <mail@aparcar.org>
Thu, 27 Aug 2020 21:47:07 +0000 (11:47 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 31 Aug 2020 10:26:10 +0000 (11:26 +0100)
The line of default packages became very long and it is easier to read
one package per line, therefore split it by newlines and sort it
alphabetically.

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/target.mk

index b0c563a0efddc985c8ffcbe53bf0a31e70039a31..03550c6ca646dac04778c7263280e90237079eb8 100644 (file)
@@ -13,13 +13,42 @@ __target_inc=1
 DEVICE_TYPE?=router
 
 # Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files busybox ca-bundle dropbear fstools libc libgcc logd libustream-wolfssl mtd netifd opkg uci uclient-fetch urandom-seed urngd
+DEFAULT_PACKAGES:=\
+       base-files \
+       busybox \
+       ca-bundle \
+       dropbear \
+       fstools \
+       libc \
+       libgcc \
+       libustream-wolfssl \
+       logd \
+       mtd \
+       netifd \
+       opkg \
+       uci \
+       uclient-fetch \
+       urandom-seed \
+       urngd
 # For the basic set
 DEFAULT_PACKAGES.basic:=
 # For nas targets
-DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
+DEFAULT_PACKAGES.nas:=\
+       block-mount \
+       fdisk \
+       lsblk \
+       mdadm
 # For router targets
-DEFAULT_PACKAGES.router:=dnsmasq iptables ip6tables ppp ppp-mod-pppoe firewall odhcpd-ipv6only odhcp6c kmod-ipt-offload
+DEFAULT_PACKAGES.router:=\
+       dnsmasq \
+       firewall \
+       ip6tables \
+       iptables \
+       kmod-ipt-offload \
+       odhcp6c \
+       odhcpd-ipv6only \
+       ppp \
+       ppp-mod-pppoe
 
 ifneq ($(DUMP),)
   all: dumpinfo