kernel: limit crypto-hw-ccp to the x86
authorRafał Miłecki <rafal@milecki.pl>
Tue, 13 Apr 2021 08:15:39 +0000 (10:15 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Tue, 13 Apr 2021 15:20:55 +0000 (17:20 +0200)
CRYPTO_DEV_CCP depends on X86 or ARM64
CRYPTO_DEV_CCP_DD depends on CPU_SUP_AMD or ARM64

Compiling this driver makes sense for x86 mainly. If one day support for
ARM64 board with AMD Secure Processor gets added this package may be
updated.

Trying to build this package on bcm4908 was causing:
ERROR: module 'build_dir/target-aarch64_cortex-a53_musl/linux-bcm4908_generic/linux-5.4.110/drivers/crypto/ccp/ccp-crypto.ko' is missing.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/kernel/linux/modules/crypto.mk

index c1b84c3181c758e5a252ade880ebc005b00d631a..2775239e5270ed72150d8f7d16cd4e4cb7735d37 100644 (file)
@@ -320,6 +320,7 @@ $(eval $(call KernelPackage,crypto-hmac))
 define KernelPackage/crypto-hw-ccp
   TITLE:=AMD Cryptographic Coprocessor
   DEPENDS:= \
+       @TARGET_x86 \
        +kmod-crypto-authenc \
        +kmod-crypto-hash \
        +kmod-crypto-manager \