omap: add support for f2fs/ext4 overlay creation
authorLucian Cristian <lucian.cristian@gmail.com>
Thu, 19 Jul 2018 06:58:42 +0000 (09:58 +0300)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 09:03:02 +0000 (11:03 +0200)
add kernel support and include the tools for creating an overlay partition (f2fs or ext4)

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
target/linux/omap/Makefile
target/linux/omap/config-4.14
target/linux/omap/config-4.9

index fc8e40dee2192a5cec8287434e67ea6fafa16af9..f22841e019b4ed4caf98789d3b885871371c2103 100644 (file)
@@ -26,4 +26,6 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))
index 7c60947e302d8491623034769f7064284db3a9fc..a94e127a443a83797448afd5ccdbef9ca1b65eac 100644 (file)
@@ -232,6 +232,11 @@ CONFIG_EXTCON=y
 CONFIG_EXTCON_PALMAS=y
 CONFIG_EXTCON_USB_GPIO=y
 CONFIG_FANOTIFY=y
+# CONFIG_F2FS_CHECK_FS is not set
+CONFIG_F2FS_FS=y
+# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_STAT_FS=y
 CONFIG_FAT_FS=y
 CONFIG_FB_CMDLINE=y
 CONFIG_FHANDLE=y
index 4272c2f90f1c86e4850457a95c0335cfd8b1d537..9cd40843088b0362ef7a111bc154b6b9a6e2feb0 100644 (file)
@@ -229,6 +229,11 @@ CONFIG_EXTCON=y
 CONFIG_EXTCON_PALMAS=y
 CONFIG_EXTCON_USB_GPIO=y
 CONFIG_FANOTIFY=y
+# CONFIG_F2FS_CHECK_FS is not set
+CONFIG_F2FS_FS=y
+# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_STAT_FS=y
 CONFIG_FAT_FS=y
 CONFIG_FB_CMDLINE=y
 CONFIG_FHANDLE=y