armvirt: 64: add Allwinner A3/A83T/A64 (sun8i family) Ethernet
authorMathew McBride <matt@traverse.com.au>
Mon, 20 Mar 2023 02:53:31 +0000 (02:53 +0000)
committerPetr Štetiar <ynezz@true.cz>
Tue, 13 Jun 2023 12:14:24 +0000 (14:14 +0200)
Add support for the dwmac (stmmac) variant used by Allwinner
Arm64 boards.

Signed-off-by: Mathew McBride <matt@traverse.com.au>
(cherry picked from commit 847467a5729995a98aa34329f6fa0ed4cb79d210)

target/linux/armvirt/image/Makefile
target/linux/armvirt/modules.mk

index 928ee3ce855b7171608ddb83179894f45d238649..a4c0c17ec605df8c02075b9dfb23d70c2ce30a7d 100644 (file)
@@ -109,7 +109,7 @@ define Device/generic
        kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
        kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
        kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
-       kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell
+       kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
        kmod-phy-marvell-10g kmod-atlantic
 endef
 TARGET_DEVICES += generic
index e9555f0184be597319d9748e38491f96376b25a3..f94b25aad43b917ce5762a357b2bfd57d2a7daf5 100644 (file)
@@ -233,6 +233,17 @@ endef
 
 $(eval $(call KernelPackage,dwmac-imx))
 
+define KernelPackage/dwmac-sun8i
+  SUBMENU=$(NETWORK_DEVICES_MENU)
+  TITLE:=Allwinner H3/A83T/A64 (sun8i) Ethernet
+  DEPENDS:=+kmod-stmmac-core +kmod-mdio-bus-mux
+  KCONFIG:=CONFIG_DWMAC_SUN8I
+  FILES=$(LINUX_DIR)/drivers/net/ethernet/stmicro/stmmac/dwmac-sun8i.ko
+  AUTOLOAD=$(call AutoLoad,45,dwmac-sun8i)
+endef
+
+$(eval $(call KernelPackage,dwmac-sun8i))
+
 define KernelPackage/thunderx-net
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Marvell (Cavium) ThunderX/2 network drivers