ipq40xx: meraki-mr33, meraki-mr74: disable image generation
authorLech Perczak <lech.perczak@gmail.com>
Wed, 21 Jun 2023 00:30:20 +0000 (02:30 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 25 Jun 2023 10:34:47 +0000 (12:34 +0200)
After migrating to kernel 5.15, upgrading causes the units to become
soft-bricked, hanging forever at the kernel startup.
Kernel size limitation of 4000000 bytes is suspected here, but this is
not fully confirmed.

Disable the images to protect users from inadvertent bricking of units,
because recovery of those is painful with Cisco's U-boot, until the root
cause is found and fixed.

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
(cherry picked from commit 9d64cc068fbb15d9e6498c1eba79851823b2f4f5)

target/linux/ipq40xx/image/generic.mk

index 59d4f082ff8b481490fe6ebbfc909b264183d745..671fca16827e53d6fb4574e139aa3d71639365c8 100644 (file)
@@ -764,6 +764,7 @@ define Device/meraki_mr33
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
+       DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr33
 
@@ -776,6 +777,7 @@ define Device/meraki_mr74
        PAGESIZE := 2048
        DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
        DEVICE_DTS_CONFIG := config@3
+       DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr74