Revert "ipq807x: add initial support for prpl Foundation Haze board"
authorPetr Štetiar <ynezz@true.cz>
Mon, 5 Jun 2023 09:45:30 +0000 (11:45 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 5 Jun 2023 09:46:47 +0000 (11:46 +0200)
This reverts commit 48603a271e6ff9e5cd851e873429893115e00c94 as this
was commited by accident, its still work in progress.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/boot/uboot-envtools/files/ipq807x
target/linux/ipq807x/base-files/etc/board.d/02_network
target/linux/ipq807x/base-files/etc/hotplug.d/firmware/11-ath11k-caldata
target/linux/ipq807x/base-files/lib/upgrade/platform.sh
target/linux/ipq807x/files/arch/arm64/boot/dts/qcom/ipq8072-haze.dts [deleted file]
target/linux/ipq807x/image/generic.mk

index 345cdadebee5ddc50e420e3e82bc76b5b8cee767..0185c2c8e6fcae28e90bdcbca47c8eeea6a16652 100644 (file)
@@ -36,11 +36,6 @@ xiaomi,ax9000)
        [ -n "$idx2" ] && \
                ubootenv_add_uci_sys_config "/dev/mtd$idx2" "0x0" "0x10000" "0x20000"
        ;;
-prpl,haze)
-       mmcpart="$(find_mmc_part 0:APPSBLENV)"
-       [ -n "$mmcpart" ] && \
-               ubootenv_add_uci_config "$mmcpart" "0x0" "0x40000" "0x400" "0x100"
-       ;;
 qnap,301w)
        idx="$(find_mtd_index 0:appsblenv)"
        [ -n "$idx" ] && \
index 8175a99f97ee1707b1ce5681b4384ef9ff2405f2..edd1e131b665a4fd9acae0d9aee53455b8e96a85 100644 (file)
@@ -25,9 +25,6 @@ ipq807x_setup_interfaces()
        netgear,wax218)
                ucidef_set_interface_lan "lan" "dhcp"
                ;;
-       prpl,haze)
-               ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
-               ;;
        qnap,301w)
                ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4 10g-2" "10g-1"
                ;;
index f9315573ec41916253cc49a21abb44022087209f..ddb0737d209fd78d4d096fbebe7b04777c044684 100644 (file)
@@ -22,17 +22,10 @@ case "$FIRMWARE" in
        zyxel,nbg7815)
                caldata_extract "0:art" 0x1000 0x20000
                ;;
-       prpl,haze)
-                caldata_extract_mmc "0:ART" 0x1000 0x20000
-               ;;
        esac
        ;;
-"ath11k/QCN9074/hw1.0/cal-pci-0000:01:00.0.bin"|\
-"ath11k/QCN9074/hw1.0/cal-pci-0001:01:00.0.bin")
+"ath11k/QCN9074/hw1.0/cal-pci-0000:01:00.0.bin")
        case "$board" in
-       prpl,haze)
-                caldata_extract_mmc "0:ART" 0x26800 0x20000
-               ;;
        xiaomi,ax9000)
                caldata_extract "0:art" 0x26800 0x20000
                ;;
index 458eb16b795c604011dbd270c41c8d004b4bb909..f7c477231504b92b5449708c951fab061fed1920 100644 (file)
@@ -71,7 +71,6 @@ platform_do_upgrade() {
        netgear,wax218)
                nand_do_upgrade "$1"
                ;;
-       prpl,haze|\
        qnap,301w)
                kernelname="0:HLOS"
                rootfsname="rootfs"
diff --git a/target/linux/ipq807x/files/arch/arm64/boot/dts/qcom/ipq8072-haze.dts b/target/linux/ipq807x/files/arch/arm64/boot/dts/qcom/ipq8072-haze.dts
deleted file mode 100644 (file)
index e47561a..0000000
+++ /dev/null
@@ -1,311 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-/dts-v1/;
-
-#include "ipq8074.dtsi"
-#include "ipq8074-hk-cpu.dtsi"
-#include "ipq8074-ess.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/leds/common.h>
-
-/ {
-       model = "prpl Foundation Haze";
-       compatible = "prpl,haze", "qcom,ipq8074";
-
-       aliases {
-               serial0 = &blsp1_uart5;
-               /* Aliases are required by U-Boot to patch MAC addresses */
-               ethernet0 = &dp6_syn;
-               ethernet1 = &dp4;
-               ethernet2 = &dp3;
-               ethernet3 = &dp2;
-               label-mac-device = &dp6_syn;
-       };
-
-       chosen {
-               stdout-path = "serial0:115200n8";
-       };
-
-       keys {
-               compatible = "gpio-keys";
-               pinctrl-0 = <&button_pins>;
-               pinctrl-names = "default";
-
-               wps-button {
-                       label = "wps";
-                       gpios = <&tlmm 42 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-
-               reset-button {
-                       label = "reset";
-                       gpios = <&tlmm 44 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-};
-
-&tlmm {
-       mdio_pins: mdio-state {
-               mdc-pins {
-                       pins = "gpio68";
-                       function = "mdc";
-                       drive-strength = <8>;
-                       bias-pull-up;
-               };
-
-               mdio-pins {
-                       pins = "gpio69";
-                       function = "mdio";
-                       drive-strength = <8>;
-                       bias-pull-up;
-               };
-       };
-
-       button_pins: button-state {
-               wps-pins {
-                       pins = "gpio42";
-                       function = "gpio";
-                       drive-strength = <8>;
-                       bias-pull-up;
-               };
-
-               rst-pins {
-                       pins = "gpio44";
-                       function = "gpio";
-                       drive-strength = <8>;
-                       bias-pull-up;
-               };
-       };
-};
-
-&blsp1_uart5 {
-       status = "okay";
-};
-
-&prng {
-       status = "okay";
-};
-
-&ssphy_0 {
-       status = "okay";
-};
-
-&qusb_phy_0 {
-       status = "okay";
-};
-
-&ssphy_1 {
-       status = "okay";
-};
-
-&qusb_phy_1 {
-       status = "okay";
-};
-
-&usb_0 {
-       status = "okay";
-};
-
-&usb_1 {
-       status = "okay";
-};
-
-&cryptobam {
-       status = "okay";
-};
-
-&crypto {
-       status = "okay";
-};
-
-&qpic_bam {
-       status = "okay";
-};
-
-&blsp1_spi1 { /* BLSP1 QUP1 */
-       pinctrl-0 = <&spi_0_pins>;
-       pinctrl-names = "default";
-       cs-gpios = <0>;
-       status = "okay";
-
-       flash@0 {
-               #address-cells = <1>;
-               #size-cells = <1>;
-               reg = <0>;
-               compatible = "jedec,spi-nor";
-               spi-max-frequency = <50000000>;
-
-               partitions {
-                       compatible = "qcom,smem-part";
-               };
-       };
-};
-
-&mdio {
-       status = "okay";
-
-       pinctrl-0 = <&mdio_pins>;
-       pinctrl-names = "default";
-       reset-gpios = <&tlmm 22 GPIO_ACTIVE_LOW>;
-
-       qca8075_1: ethernet-phy@0 {
-               compatible = "ethernet-phy-ieee802.3-c22";
-               reg = <0>;
-       };
-
-       qca8075_2: ethernet-phy@1 {
-               compatible = "ethernet-phy-ieee802.3-c22";
-               reg = <1>;
-       };
-
-       qca8075_3: ethernet-phy@2 {
-               compatible = "ethernet-phy-ieee802.3-c22";
-               reg = <2>;
-       };
-
-       qca8075_4: ethernet-phy@3 {
-               compatible = "ethernet-phy-ieee802.3-c22";
-               reg = <3>;
-       };
-
-       aqr113c: ethernet-phy@5 {
-               compatible ="ethernet-phy-ieee802.3-c45";
-               reg = <8>;
-               reset-gpios = <&tlmm 43 GPIO_ACTIVE_LOW>;
-       };
-};
-
-&sdhc_1 {
-       status = "okay";
-
-       mmc-hs400-1_8v;
-       mmc-hs200-1_8v;
-       mmc-ddr-1_8v;
-       vqmmc-supply = <&l11>;
-};
-
-&switch {
-       status = "okay";
-
-       switch_cpu_bmp = <0x1>;  /* cpu port bitmap */
-       switch_lan_bmp = <0x1e>; /* lan port bitmap */
-       switch_wan_bmp = <0x60>; /* wan port bitmap */
-       switch_mac_mode = <0x0>; /* mac mode for uniphy instance0*/
-       switch_mac_mode1 = <0xe>; /* mac mode for uniphy instance1*/
-       switch_mac_mode2 = <0xd>; /* mac mode for uniphy instance2*/
-       bm_tick_mode = <0>; /* bm tick mode */
-       tm_tick_mode = <0>; /* tm tick mode */
-
-       qcom,port_phyinfo {
-               port@0 {
-                       port_id = <1>;
-                       phy_address = <0>;
-               };
-               port@1 {
-                       port_id = <2>;
-                       phy_address = <1>;
-               };
-               port@2 {
-                       port_id = <3>;
-                       phy_address = <2>;
-               };
-               port@3 {
-                       port_id = <4>;
-                       phy_address = <3>;
-               };
-               port@4 {
-                       port_id = <6>;
-                       phy_address = <8>;
-                       compatible = "ethernet-phy-ieee802.3-c45";
-                       ethernet-phy-ieee802.3-c45;
-               };
-       };
-};
-
-&edma {
-       status = "okay";
-};
-
-/* Dummy LAN port */
-&dp1 {
-       status = "disabled";
-       phy-handle = <&qca8075_1>;
-       label = "lan4";
-};
-
-&dp2 {
-       status = "okay";
-       phy-handle = <&qca8075_2>;
-       label = "lan3";
-};
-
-&dp3 {
-       status = "okay";
-       phy-handle = <&qca8075_3>;
-       label = "lan2";
-};
-
-&dp4 {
-       status = "okay";
-       phy-handle = <&qca8075_4>;
-       label = "lan1";
-};
-
-&dp6_syn {
-       status = "okay";
-       qcom,mactype = <1>;
-       phy-handle = <&aqr113c>;
-       label = "wan";
-};
-
-&pcie_qmp0 {
-       status = "okay";
-};
-
-&pcie0 {
-       status = "okay";
-
-       perst-gpio = <&tlmm 58 GPIO_ACTIVE_LOW>;
-
-       bridge@0,0 {
-               reg = <0x00020000 0 0 0 0>;
-               #address-cells = <3>;
-               #size-cells = <2>;
-               ranges;
-       };
-};
-
-&pcie_qmp1 {
-       status = "okay";
-};
-
-&pcie1 {
-       status = "okay";
-
-       perst-gpio = <&tlmm 61 GPIO_ACTIVE_LOW>;
-
-       bridge@1,0 {
-               reg = <0x00010000 0 0 0 0>;
-               #address-cells = <3>;
-               #size-cells = <2>;
-               ranges;
-
-               wifi@1,0 {
-                       status = "okay";
-
-                       /* ath11k has no DT compatible for PCI cards */
-                       compatible = "pci17cb,1104";
-                       reg = <0x00010000 0 0 0 0>;
-
-                       qcom,ath11k-calibration-variant = "prpl-Haze";
-               };
-       };
-};
-
-&wifi {
-       status = "okay";
-
-       qcom,ath11k-calibration-variant = "prpl-Haze";
-};
index 92a1e37828adf26a37e1d98735a2943aa43b38da..1ea42845f01d35ee06e2cf6711691df1dc537646 100644 (file)
@@ -108,18 +108,6 @@ define Device/netgear_wax218
 endef
 TARGET_DEVICES += netgear_wax218
 
-define Device/prpl_haze
-       $(call Device/FitImage)
-       $(call Device/EmmcImage)
-       DEVICE_VENDOR := prpl Foundation
-       DEVICE_MODEL := Haze
-       DEVICE_DTS_CONFIG := config@hk09
-       SOC := ipq8072
-       DEVICE_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci
-       DEFAULT_PACKAGES += ath11k-firmware-qcn9074 ipq-wifi-prpl_haze kmod-ath11k-pci
-endef
-TARGET_DEVICES += prpl_haze
-
 define Device/qnap_301w
        $(call Device/FitImage)
        $(call Device/EmmcImage)