Makefile: fix stray \ warnings with grep-3.8
authorNick Hainke <vincent@systemli.org>
Sun, 11 Sep 2022 06:15:52 +0000 (08:15 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 27 Sep 2022 14:45:08 +0000 (16:45 +0200)
We simply grep for "/usr". So no need for "-E" or "\/". Furthermore, in
the new grep versions this creates warnings.

As written in the grep-3.8 announcement:
  Regular expressions with stray backslashes now cause warnings, as
  their unspecified behavior can lead to unexpected results.
  For example, '\a' and 'a' are not always equivalent
  <https://bugs.gnu.org/39678>.

Fixes warnings in the form of:
  grep: warning: stray \ before /

Signed-off-by: Nick Hainke <vincent@systemli.org>
Makefile

index bfb52c5ddd63ee2c38d4639c5fd7226e9103667f..cbf9fa2cd1385e93d8e77cf961a69cfe9445b5be 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
 
 world:
 
-DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -E '\/usr' -m 1)
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
 export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)