tools/mklibs: Fix compile with GCC 11
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 16 May 2021 21:49:48 +0000 (23:49 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 16 May 2021 21:55:26 +0000 (23:55 +0200)
GCC 11 defaults to C++17, but mklibs does not compile when using the
C++17 standard. This patch switches back to the gnu++98 version like
done in master commit 9437012b9ee4 ("tools/mklibs: update to 0.1.44 and
convert to Python 3")

This fixes the following compile error message:
elf.hpp:52:56: error: ISO C++17 does not allow dynamic exception specifications
   52 |       const section &get_section(unsigned int i) const throw (std::out_of_range) { return *sections.at(i); };

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
tools/mklibs/Makefile

index 507c2fd3949e2fc2af6c9e872393012fd914a523..8826840524c918bb76aafb368667f42fcfac34f2 100644 (file)
@@ -18,6 +18,7 @@ HOST_FIXUP:=autoreconf
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CFLAGS += -I$(CURDIR)/include
+HOST_CPPFLAGS += -std=gnu++98
 
 define Host/Install
        $(INSTALL_BIN) \