Revert "prereq: SetupHostCommand: fix wrong check result"
authorMichael Pratt <mcpratt@pm.me>
Thu, 25 May 2023 07:00:57 +0000 (03:00 -0400)
committerPetr Štetiar <ynezz@true.cz>
Mon, 5 Jun 2023 06:31:49 +0000 (08:31 +0200)
This reverts commit 7855378fcd7ed7cb0a223238a99bac0b8e46c380.

The return "exit 1" was intentional and actually just
makes the symlink checks much more strict.

This new level of strictness added to the checks revealed
what was a confusing regression with prereq stage that
already existed but was not presenting itself
because of the simple way that checks used to be done before.

Either way, reverting to "exit 0" was a nice workaround
until the true root cause was discovered, so as to not interfere
with others' pull requests and builds in the meantime.

It turns out that this problem was the inconsistent value of $PATH
between different commands within the SetupHostCommand recipe,
now fixed in the parent commit, using the variable created
in the parent of the parent commit.

Ref: f75204036c ("prereq-build: allow host command symlinks to update")
Signed-off-by: Michael Pratt <mcpratt@pm.me>
include/prereq.mk

index 45c84e984c6f2942ac34b7b2a5153bcfcf8969ac..c72878ebb0eb0a0f0502393653b02594d4cf5bbb 100644 (file)
@@ -112,7 +112,7 @@ define SetupHostCommand
                                                ;; \
                                esac; \
                                ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \
-                               exit 0; \
+                               exit 1; \
                        fi; \
                fi; \
        done; \