kernel: Update kernel 4.14 to version 4.14.206
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 6 Nov 2020 18:02:47 +0000 (19:02 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 10 Nov 2020 23:49:32 +0000 (00:49 +0100)
Compile and runtime tested on x86/64.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
16 files changed:
include/kernel-version.mk
target/linux/cns3xxx/patches-4.14/210-dwc2_defaults.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/hack-4.14/204-module_strip.patch
target/linux/generic/hack-4.14/930-crashlog.patch
target/linux/generic/pending-4.14/203-kallsyms_uncompressed.patch
target/linux/generic/pending-4.14/920-mangle_bootargs.patch
target/linux/ipq806x/patches-4.14/0067-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/mediatek/patches-4.14/0064-dts.patch
target/linux/mediatek/patches-4.14/0124-arm64-mediatek-cleanup-message-for-platform-selectio.patch
target/linux/mvebu/patches-4.14/006-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/mvebu/patches-4.14/411-sfp-add-sfp-compatible.patch
target/linux/mvebu/patches-4.14/521-esporessobin-dt-enable-spi-nor-on-i2c.patch
target/linux/mvebu/patches-4.14/528-arm64-dts-armada-3720-espressobin-set-max-link-to-ge.patch
target/linux/octeon/patches-4.14/110-er200-ethernet_probe_order.patch
target/linux/oxnas/patches-4.14/996-generic-Mangle-bootloader-s-kernel-arguments.patch

index bdcd01686c43ec2e664306ce1c05e015fbec8424..e22f10c577d2720993fbf9ec5d4f44b6eb60d38b 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .240
-LINUX_VERSION-4.14 = .202
+LINUX_VERSION-4.14 = .206
 
 LINUX_KERNEL_HASH-4.9.240 = 06e470c66988da200ae95dc5d5fdfd1e1f8611e8c3445620e3566ecd0bdf776f
-LINUX_KERNEL_HASH-4.14.202 = 95c717ab5b0bdd2333e829f0507385fbe3424ceee810727f3a8551a0c74be328
+LINUX_KERNEL_HASH-4.14.206 = 1c233efaa5063983293a02d4692acc9ced9c03e18857364855d4f612347086ac
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 67f152f43de1f7f57cdf998c3ff038a0af439045..0cc4dd1830f6ac23a93428a61b0128c935c12da6 100644 (file)
@@ -43,7 +43,7 @@
  {
 +      /*
        const struct of_device_id *match;
-       void (*set_params)(void *data);
+       void (*set_params)(struct dwc2_hsotg *data);
 +      */
  
        dwc2_set_default_params(hsotg);
index ebd90a8ef2e400f259496092ecea6bec88ff9b0c..4ad22b3de1d8ee9f120f59fc6517de893325bdf2 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -2001,7 +2001,8 @@ static const struct usb_device_id option
+@@ -2011,7 +2011,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index c53963c5304f5cb305bd141fac42a778f5754253..d93b545b7ceccde15d5f4c87f9ef69e0fbe74fe7 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1903,6 +1903,13 @@ config TRIM_UNUSED_KSYMS
+@@ -1904,6 +1904,13 @@ config TRIM_UNUSED_KSYMS
  
          If unsure, or if you need to build out-of-tree modules, say N.
  
index 9d09dbd760a89718d8486c561b0bd1bd020894b0..2da51fb406a9c2a467ab08f4db7b7c75e0d751f7 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +#endif
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1009,6 +1009,10 @@ config RELAY
+@@ -1010,6 +1010,10 @@ config RELAY
  
          If unsure, say N.
  
index 1f5c83e94f56437b91efc1a5f1f89734175fc215..159a79988f3fb542c734c67df131dab5a821941d 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1081,6 +1081,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
+@@ -1082,6 +1082,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
          the unaligned access emulation.
          see arch/parisc/kernel/unaligned.c for reference
  
index 2f6a52c23d65b61678cfbbcbbe23b2f5a923a02b..4d7dd3364d95789b9d48c094c25a655b5f33a799 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1427,6 +1427,15 @@ config EMBEDDED
+@@ -1428,6 +1428,15 @@ config EMBEDDED
          an embedded system so certain expert options are available
          for configuration.
  
index f0cc3ed509042ea29f361a62fdb54eeac79adcf8..c977dd1001d74cbb736d426df1e17021fbbc1148 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index a2f5000d4d16975d89c626fb67705583e4a6fbd7..8cfda5003597a78bd977ae94c2e04fb1484a5e3e 100644 (file)
                                        reg = <6>;
                                        label = "cpu";
                                        ethernet = <&gmac0>;
-@@ -187,8 +227,6 @@
+@@ -188,8 +228,6 @@
                                };
                        };
                };
index 6af0ae83163a637daa74906b609d3d97321d0890..1f8a549aac73b23246c911798731da1e38dd8b5f 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Matthias Brugger <matthias.bgg@gmail.com>
 
 --- a/arch/arm64/Kconfig.platforms
 +++ b/arch/arm64/Kconfig.platforms
-@@ -91,12 +91,13 @@ config ARCH_HISI
+@@ -92,12 +92,13 @@ config ARCH_HISI
          This enables support for Hisilicon ARMv8 SoC family
  
  config ARCH_MEDIATEK
index 4ef86edb6ab492ec9d7a505b4466d97b85230c81..f9d902b4d988650d8276da205b8d28bbc8edf7e3 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 9174765e6a34cdc76c59f6e7388d64b6d937f271..6fce278305160d8d557a82f16bf968de2fdbc21e 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/net/phy/sfp.c
 +++ b/drivers/net/phy/sfp.c
-@@ -1168,6 +1168,7 @@ static int sfp_remove(struct platform_de
+@@ -1169,6 +1169,7 @@ static int sfp_remove(struct platform_de
  
  static const struct of_device_id sfp_of_match[] = {
        { .compatible = "sff,sfp", },
index 3cabaa7a01b07560c6829b56a3451c61c7163674..35eb136163db1b3d2f74ce0001d3ec99d2080eb8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
-@@ -111,6 +111,26 @@
+@@ -115,6 +115,26 @@
        status = "okay";
  };
  
index 5ff9b472682c9c568f75254e38450eceaee9562b..6ce49f71f0c7f20354aa7fcd01628d70878f2cc3 100644 (file)
@@ -62,7 +62,7 @@ Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
 
 --- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
 +++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
-@@ -79,6 +79,8 @@
+@@ -83,6 +83,8 @@
  /* J9 */
  &pcie0 {
        status = "okay";
index 6b1eaf92a2b0c06b7e416700437898f2513e89ab..e5330ffbd68a8d4b10273c7b355fc86e1c31cf16 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/staging/octeon/ethernet.c
 +++ b/drivers/staging/octeon/ethernet.c
-@@ -673,6 +673,7 @@ static int cvm_oct_probe(struct platform
+@@ -674,6 +674,7 @@ static int cvm_oct_probe(struct platform
        int interface;
        int fau = FAU_NUM_PACKET_BUFFERS_TO_FREE;
        int qos;
@@ -8,7 +8,7 @@
        struct device_node *pip;
        int mtu_overhead = ETH_HLEN + ETH_FCS_LEN;
  
-@@ -796,13 +797,19 @@ static int cvm_oct_probe(struct platform
+@@ -797,13 +798,19 @@ static int cvm_oct_probe(struct platform
        }
  
        num_interfaces = cvmx_helper_get_number_of_interfaces();
index a06825f7c87b4ff7361c8b7ebb8e1bdbb5205556..313b9b564010d12bf3d720fc4dcf09e11decbef0 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1934,6 +1934,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1936,6 +1936,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.