kernel: hwmon: add dme1737 driver
authorLucian Cristian <lucian.cristian@gmail.com>
Thu, 2 Apr 2020 11:17:00 +0000 (14:17 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Apr 2020 20:11:22 +0000 (22:11 +0200)
SMSC DME1737, SCH3112, SCH3114, SCH3116, SCH5027 monitoring support

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
package/kernel/linux/modules/hwmon.mk

index 2552a32a560b5d1138e4129dd2ec84503f4c28cf..159c0eac9ae77c5c2459bb8eecb0b8eb0cff3f8c 100644 (file)
@@ -77,6 +77,22 @@ endef
 $(eval $(call KernelPackage,hwmon-adt7475))
 
 
+define KernelPackage/hwmon-dme1737
+  TITLE:=SMSC DME1737 and compatible monitoring support
+  KCONFIG:=CONFIG_SENSORS_DME1737
+  FILES:= \
+       $(LINUX_DIR)/drivers/hwmon/dme1737.ko
+  AUTOLOAD:=$(call AutoProbe,dme1737)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-dme1737/description
+ SMSC DME1737, SCH3112, SCH3114, SCH3116, SCH5027 monitoring support
+endef
+
+$(eval $(call KernelPackage,hwmon-dme1737))
+
+
 define KernelPackage/hwmon-drivetemp
   TITLE:=Hard disk drives with temperature sensor
   KCONFIG:=CONFIG_SENSORS_DRIVETEMP