ubox: add acl file for logd
authorFelix Fietkau <nbd@nbd.name>
Tue, 28 Nov 2023 11:51:37 +0000 (12:51 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 28 Nov 2023 12:57:34 +0000 (13:57 +0100)
Fixes ubus reconnect, since the process user id changes to 'logd'

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/system/ubox/Makefile
package/system/ubox/files/logd.json [new file with mode: 0644]

index e91763b074db35bc5bfdfb6a2375b9681f45b683..17bade25e416ff5a1a733abcab089ee66e301241 100644 (file)
@@ -63,10 +63,11 @@ define Package/ubox/install
 endef
 
 define Package/logd/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d/
+       $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d/ $(1)/usr/share/acl.d
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{logd,logread} $(1)/sbin/
        $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+       $(INSTALL_DATA) ./files/logd.json $(1)/usr/share/acl.d
 endef
 
 $(eval $(call BuildPackage,ubox))
diff --git a/package/system/ubox/files/logd.json b/package/system/ubox/files/logd.json
new file mode 100644 (file)
index 0000000..f0b2fb1
--- /dev/null
@@ -0,0 +1,4 @@
+{
+       "user": "logd",
+       "publish": [ "log" ]
+}