build: add GNU install to prerequisites
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 4 Jan 2021 20:55:38 +0000 (20:55 +0000)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 24 Mar 2021 23:51:57 +0000 (23:51 +0000)
The recent removal of usbutils from core and replacement by hwdata in
packages has exposed hwdata's requirement for certain GNU options on
'install' (-T)  Other packages (sqm-scripts) have openwrt specific
makefile sections to avoid GNU options but I suspect this is going to
get harder in the future.

Add GNU install as a prerequisite and link into
$STAGING_DIR/host/etc/bin as per similar GNU utils

This resolves an issue building under MacOS which would otherwise use a
non-GNU options aware version of 'install'

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
include/prereq-build.mk

index b2526a1ec10cab8a76263cbf0728a121fff86174..0375ef6861a4177eafa14f75cf1954da69225924 100644 (file)
@@ -136,6 +136,10 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
 $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
        wget --version | grep GNU))
 
+$(eval $(call SetupHostCommand,install,Please install GNU 'install', \
+       install --version | grep GNU, \
+       ginstall --version | grep GNU))
+
 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))