elfutils: enable host build
authorLucian Cristian <lucian.cristian@gmail.com>
Tue, 31 Aug 2021 07:04:36 +0000 (10:04 +0300)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 31 Oct 2021 23:56:51 +0000 (00:56 +0100)
frr 8.0 needs host libelf dev
add option for host build
tested on x86, ramips, kirkwood

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
[changed commit author's email]
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/libs/elfutils/Makefile

index d595e4caf22cc3c9bd4102c3f5a2134d4ac928ed..b0c9b8bd8ca5f23edaa09f465912eb6d043b7758 100644 (file)
@@ -26,6 +26,7 @@ PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/elfutils/Default
   SECTION:=libs
@@ -60,6 +61,12 @@ else
 CONFIGURE_ARGS += --disable-nls
 endif
 
+HOST_CONFIGURE_ARGS += \
+       --disable-debuginfod \
+       --disable-libdebuginfod \
+       --without-lzma \
+       --without-zstd
+
 CONFIGURE_ARGS += \
        --program-prefix=eu- \
        --disable-debuginfod \
@@ -97,6 +104,7 @@ define Package/libelf/install
 endef
 
 # these lines need to be ordered by dependency because of ABI versioning
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,libelf))
 $(eval $(call BuildPackage,libdw))
 $(eval $(call BuildPackage,libasm))