prereq-build: add check for stdlib
authorRosen Penev <rosenp@gmail.com>
Fri, 9 Sep 2022 19:31:44 +0000 (12:31 -0700)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 11 Sep 2022 14:12:29 +0000 (16:12 +0200)
One way to solve the python3 dependency check is to install
python3-minimal instead of python3 on Debian based systems.
Unfortunately, this results in a fairly unusable python.

Added check for ntpath, which is how the issue originally presented
itself.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/prereq-build.mk

index 67993cf7e30ef745cee371344f47237482d48de5..e1687da370dfd7cedc68d4cd9dc8e209b4b9c2b9 100644 (file)
@@ -190,6 +190,10 @@ $(eval $(call TestHostCommand,python3-distutils, \
        Please install the Python3 distutils module, \
        $(STAGING_DIR_HOST)/bin/python3 -c 'from distutils import util'))
 
+$(eval $(call TestHostCommand,python3-stdlib, \
+       Please install the Python3 stdlib module, \
+       $(STAGING_DIR_HOST)/bin/python3 -c 'import ntpath'))
+
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))