realtek: don't relocate kernel on HPE 1920 series
authorJan Hoffmann <jan@3e8.eu>
Thu, 5 Jan 2023 21:36:24 +0000 (22:36 +0100)
committerSander Vanheule <sander@svanheule.net>
Sat, 7 Jan 2023 10:16:59 +0000 (11:16 +0100)
This is no longer needed now that the kernel is built with a load
address that matches the one hard-coded in the bootloader.

Signed-off-by: Jan Hoffmann <jan@3e8.eu>
target/linux/realtek/image/Makefile
target/linux/realtek/image/common.mk

index 82390212e62d55e39e70e17a6b919d42fa790c9f..3dfbcf67c166807bb400923116fa232b176e5055 100644 (file)
@@ -71,20 +71,6 @@ define Build/h3c-vfs
        mv $@.new $@
 endef
 
-define Build/relocate-kernel
-       rm -rf $@.relocate
-       $(CP) ../../generic/image/relocate $@.relocate
-       $(MAKE) -j1 -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) LZMA_TEXT_START=0x82000000 \
-               CROSS_COMPILE=$(TARGET_CROSS)
-       ( \
-               dd if=$@.relocate/loader.bin bs=32 conv=sync && \
-               perl -e '@s = stat("$@"); print pack("N", @s[7])' && \
-               cat "$@" \
-       ) > "$@.new"
-       mv "$@.new" "$@"
-       rm -rf $@.relocate
-endef
-
 define Device/Default
   PROFILES = Default
   KERNEL := \
index 8f536bf15f5886e3a94874d6a57c2fd4dafd9821..214683f8e95923794753cf5b569d39975fad2c9a 100644 (file)
@@ -34,14 +34,12 @@ define Device/hpe_1920
   KERNEL := \
        kernel-bin | \
        append-dtb | \
-       relocate-kernel | \
        7z | \
        h3c-image | \
        h3c-vfs
   KERNEL_INITRAMFS := \
        kernel-bin | \
        append-dtb | \
-       relocate-kernel | \
        7z | \
        h3c-image
   IMAGE/sysupgrade.bin := \