nftables: install package file
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 29 Nov 2021 20:30:42 +0000 (20:30 +0000)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Tue, 30 Nov 2021 15:16:17 +0000 (15:16 +0000)
Install pc file so dnsmasq can find libnftables

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/utils/nftables/Makefile

index 89bb10e0daf4e1d297335e8a547e65063991708d..49c56ee6c383c14abb13dc7177e63e995d79708a 100644 (file)
@@ -65,6 +65,9 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/nftables $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnftables.pc \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/nftables/install/Default