kernel: bump 5.15 to 5.15.124
authorJohn Audia <therealgraysky@proton.me>
Thu, 3 Aug 2023 17:53:47 +0000 (13:53 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 10 Aug 2023 19:06:55 +0000 (21:06 +0200)
Changelog: https://lore.kernel.org/stable/2023080341-curliness-salary-4158@gregkh/

1. Needed to make a change to to package/kernel/linux/modules/netsupport.mk
   due to upstream moving vxlan to its own directory[1].  @john-tho suggested
   using the the 6.1 xvlan FILES to circumvent.
2. All patches automatically rebased.

1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.124&id=77396fa9096abdbfbb87d63e73ad44d5621cf103

Signed-off-by: John Audia <therealgraysky@proton.me>
[Refreshed on top of OpenWrt 23.05]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 81c1172c3626157ff9a146430cd14e32c9c80a5a)

26 files changed:
include/kernel-5.15
package/kernel/linux/modules/netsupport.mk
target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch
target/linux/bcm27xx/patches-5.15/950-0281-media-i2c-Add-driver-for-Sony-IMX477-sensor.patch
target/linux/bcm27xx/patches-5.15/950-0413-Documentation-devicetree-Add-documentation-for-imx37.patch
target/linux/bcm27xx/patches-5.15/950-0468-usb-xhci-workaround-for-bogus-SET_DEQ_PENDING-endpoi.patch
target/linux/bcm27xx/patches-5.15/950-0520-dt-bindings-media-i2c-Add-IMX519-CMOS-sensor-binding.patch
target/linux/bcm27xx/patches-5.15/950-0600-xhci-quirks-add-link-TRB-quirk-for-VL805.patch
target/linux/bcm27xx/patches-5.15/950-0605-xhci-refactor-out-TRBS_PER_SEGMENT-define-in-runtime.patch
target/linux/bcm27xx/patches-5.15/950-0606-usb-xhci-add-VLI_TRB_CACHE_BUG-quirk.patch
target/linux/bcm27xx/patches-5.15/950-0717-usb-xhci-add-a-quirk-for-Superspeed-bulk-OUT-transfe.patch
target/linux/bcm27xx/patches-5.15/950-0747-usb-xhci-rework-XHCI_VLI_SS_BULK_OUT_BUG-quirk.patch
target/linux/bcm27xx/patches-5.15/950-0795-drm-tiny-Add-MIPI-DBI-compatible-SPI-driver.patch
target/linux/generic/backport-5.15/707-v6.3-net-pcs-add-driver-for-MediaTek-SGMII-PCS.patch
target/linux/generic/backport-5.15/790-v6.4-0011-net-dsa-mt7530-introduce-separate-MDIO-driver.patch
target/linux/generic/backport-5.15/790-v6.4-0013-net-dsa-mt7530-introduce-driver-for-MT7988-built-in-.patch
target/linux/generic/backport-5.15/791-v6.2-01-net-phy-Add-driver-for-Motorcomm-yt8521-gigabit-ethernet.patch
target/linux/generic/backport-5.15/804-v5.18-0009-nvmem-Add-driver-for-OCOTP-in-Sunplus-SP7021.patch
target/linux/generic/backport-5.15/806-v6.0-0001-nvmem-microchip-otpc-add-support.patch
target/linux/generic/hack-5.15/780-usb-net-MeigLink_modem_support.patch
target/linux/generic/pending-5.15/351-irqchip-bcm-6345-l1-request-memory-region.patch
target/linux/layerscape/patches-5.15/701-staging-add-fsl_ppfe-driver.patch
target/linux/mediatek/patches-5.15/730-v6.5-net-phy-add-driver-for-MediaTek-SoC-built-in-GE-PHYs.patch
target/linux/mediatek/patches-5.15/850-v6.0-i2c-move-drivers-from-strlcpy-to-strscpy.patch
target/linux/mvebu/patches-5.15/907-MAINTAINERS-Add-an-entry-for-the-IEI-WT61P803-PUZZLE.patch
target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch

index 3052c783a955f83bc11dd29a65dcb64c554bc2ef..35c6240132b900f30cd33cfe430fa9511fe789f7 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.15 = .123
-LINUX_KERNEL_HASH-5.15.123 = 2de69544a12e6a059163c58fc901c13bcf22e8cac39c66b56f8fbb633399bf93
+LINUX_VERSION-5.15 = .124
+LINUX_KERNEL_HASH-5.15.124 = 00036a0260ad012aa832a8698a4afcf23b2410091527738ce48ce3fcc23f22ed
index 7f1905311fc94f4bccb13a88449dc44d9f9a786f..1d5950d237e9d82004853202755d2bd3f8c8f64d 100644 (file)
@@ -92,7 +92,8 @@ define KernelPackage/vxlan
        +kmod-udptunnel4 \
        +IPV6:kmod-udptunnel6
   KCONFIG:=CONFIG_VXLAN
-  FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
+  FILES:= \
+       $(LINUX_DIR)/drivers/net/vxlan/vxlan.ko
   AUTOLOAD:=$(call AutoLoad,13,vxlan)
 endef
 
index f542c32d45d3f24245b224b7d7a8e98a2eda6248..1971b9cd0101855805a5e610d1f9614e3dee4d6b 100644 (file)
@@ -654,7 +654,7 @@ SVN-Revision: 35130
                return false;
  
        return true;
-@@ -750,13 +754,13 @@ static inline void ipv6_addr_set_v4mappe
+@@ -746,13 +750,13 @@ static inline void ipv6_addr_set_v4mappe
   */
  static inline int __ipv6_addr_diff32(const void *token1, const void *token2, int addrlen)
  {
@@ -670,7 +670,7 @@ SVN-Revision: 35130
                if (xb)
                        return i * 32 + 31 - __fls(ntohl(xb));
        }
-@@ -950,17 +954,18 @@ static inline u32 ip6_multipath_hash_fie
+@@ -946,17 +950,18 @@ static inline u32 ip6_multipath_hash_fie
  static inline void ip6_flow_hdr(struct ipv6hdr *hdr, unsigned int tclass,
                                __be32 flowlabel)
  {
index 289b7d8a933c4d1e88b6c8a0e3ea708b1fa7c557..18273c07784c11f9a383a16e31f9af15709366db 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Naushir Patuck <naush@raspberrypi.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17534,6 +17534,14 @@ T:    git git://linuxtv.org/media_tree.git
+@@ -17535,6 +17535,14 @@ T:    git git://linuxtv.org/media_tree.git
  F:    Documentation/devicetree/bindings/media/i2c/sony,imx412.yaml
  F:    drivers/media/i2c/imx412.c
  
index c93b69c0aa3042b704aaf4bdc5de459f15652c4d..3fc2ef4042d176037198f45c8ba291b5aae3356d 100644 (file)
@@ -132,7 +132,7 @@ Signed-off-by: David Plowman <david.plowman@raspberrypi.com>
 +...
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17548,6 +17548,7 @@ M:     Raspberry Pi Kernel Maintenance <kern
+@@ -17549,6 +17549,7 @@ M:     Raspberry Pi Kernel Maintenance <kern
  L:    linux-media@vger.kernel.org
  S:    Maintained
  T:    git git://linuxtv.org/media_tree.git
index 974094cebf2d343f428c51d83f4f0f3fe37d2d67..5248ed5954eef7534ba8ae1e79843ce576aaf970 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -697,9 +697,9 @@ deq_found:
+@@ -674,9 +674,9 @@ deq_found:
        }
  
        if ((ep->ep_state & SET_DEQ_PENDING)) {
index 4d7ab14b843767cc8c0825ee72fc4334ff4c8a17..273285bef56a779309f48f8e67cc56118802611d 100644 (file)
@@ -132,7 +132,7 @@ Signed-off-by: Lee Jackson <info@arducam.com>
 +...
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17552,6 +17552,14 @@ F:    Documentation/devicetree/bindings/med
+@@ -17553,6 +17553,14 @@ F:    Documentation/devicetree/bindings/med
  F:    Documentation/devicetree/bindings/media/i2c/imx477.yaml
  F:    drivers/media/i2c/imx477.c
  
index a0ec8f8b2b4448d99d8511189ec3eb62f35c3b95..78b01e9ba5ce5c032960afa0c95ae60e2b6d7cf9 100644 (file)
@@ -22,17 +22,21 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -297,6 +297,7 @@ static void xhci_pci_quirks(struct devic
-       if (pdev->vendor == PCI_VENDOR_ID_VIA && pdev->device == 0x3483) {
+@@ -294,8 +294,10 @@ static void xhci_pci_quirks(struct devic
+                       pdev->device == 0x3432)
+               xhci->quirks |= XHCI_BROKEN_STREAMS;
+-      if (pdev->vendor == PCI_VENDOR_ID_VIA && pdev->device == 0x3483)
++      if (pdev->vendor == PCI_VENDOR_ID_VIA && pdev->device == 0x3483) {
                xhci->quirks |= XHCI_LPM_SUPPORT;
-               xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
 +              xhci->quirks |= XHCI_AVOID_DQ_ON_LINK;
-       }
++      }
  
        if (pdev->vendor == PCI_VENDOR_ID_ASMEDIA &&
+               pdev->device == PCI_DEVICE_ID_ASMEDIA_1042_XHCI) {
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -687,6 +687,15 @@ static int xhci_move_dequeue_past_td(str
+@@ -664,6 +664,15 @@ static int xhci_move_dequeue_past_td(str
        } while (!cycle_found || !td_last_trb_found);
  
  deq_found:
index 4cb33c75297889b149494e48d47635bd07729d79..792f3bdf0fe76dc23140047eb6e37d38003e723d 100644 (file)
@@ -205,7 +205,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
                xhci_err(xhci, "Tried to move enqueue past ring segment\n");
                return;
        }
-@@ -3189,7 +3192,7 @@ irqreturn_t xhci_irq(struct usb_hcd *hcd
+@@ -3166,7 +3169,7 @@ irqreturn_t xhci_irq(struct usb_hcd *hcd
         * that clears the EHB.
         */
        while (xhci_handle_event(xhci) > 0) {
@@ -214,7 +214,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
                        continue;
                xhci_update_erst_dequeue(xhci, event_ring_deq);
                event_ring_deq = xhci->event_ring->dequeue;
-@@ -3331,7 +3334,8 @@ static int prepare_ring(struct xhci_hcd
+@@ -3308,7 +3311,8 @@ static int prepare_ring(struct xhci_hcd
                }
        }
  
index 5c7a71b42b99a3ad8c590b40903b8f12047bdc97..4e23eaf93670bf0e6f9bd98aabdce07f7712a4af 100644 (file)
@@ -53,9 +53,9 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
                        cycle_state, type, max_packet, flags);
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -298,6 +298,7 @@ static void xhci_pci_quirks(struct devic
+@@ -297,6 +297,7 @@ static void xhci_pci_quirks(struct devic
+       if (pdev->vendor == PCI_VENDOR_ID_VIA && pdev->device == 0x3483) {
                xhci->quirks |= XHCI_LPM_SUPPORT;
-               xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
                xhci->quirks |= XHCI_AVOID_DQ_ON_LINK;
 +              xhci->quirks |= XHCI_VLI_TRB_CACHE_BUG;
        }
index 67a965eff3a05608e7bc10c8be197b33e1aaa3ea..e47ab8dac41cc53a2779e5e34f0e16e7dc616bbe 100644 (file)
@@ -26,8 +26,8 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -299,6 +299,7 @@ static void xhci_pci_quirks(struct devic
-               xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
+@@ -298,6 +298,7 @@ static void xhci_pci_quirks(struct devic
+               xhci->quirks |= XHCI_LPM_SUPPORT;
                xhci->quirks |= XHCI_AVOID_DQ_ON_LINK;
                xhci->quirks |= XHCI_VLI_TRB_CACHE_BUG;
 +              xhci->quirks |= XHCI_VLI_SS_BULK_OUT_BUG;
@@ -36,7 +36,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
        if (pdev->vendor == PCI_VENDOR_ID_ASMEDIA &&
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -3644,14 +3644,15 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
+@@ -3621,14 +3621,15 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
        unsigned int num_trbs;
        unsigned int start_cycle, num_sgs = 0;
        unsigned int enqd_len, block_len, trb_buff_len, full_len;
@@ -54,7 +54,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
        full_len = urb->transfer_buffer_length;
        /* If we have scatter/gather list, we use it. */
        if (urb->num_sgs && !(urb->transfer_flags & URB_DMA_MAP_SINGLE)) {
-@@ -3688,6 +3689,17 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
+@@ -3665,6 +3666,17 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
        start_cycle = ring->cycle_state;
        send_addr = addr;
  
@@ -72,7 +72,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
        /* Queue the TRBs, even if they are zero-length */
        for (enqd_len = 0; first_trb || enqd_len < full_len;
                        enqd_len += trb_buff_len) {
-@@ -3700,6 +3712,11 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
+@@ -3677,6 +3689,11 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
                if (enqd_len + trb_buff_len > full_len)
                        trb_buff_len = full_len - enqd_len;
  
index 526fa29bcc63a21072522fe02702e43208a43e2e..79b3d196d3b8b93e24ee38274c9e0352e06f826d 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
 
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -3644,7 +3644,7 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
+@@ -3621,7 +3621,7 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
        unsigned int num_trbs;
        unsigned int start_cycle, num_sgs = 0;
        unsigned int enqd_len, block_len, trb_buff_len, full_len;
@@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
        u32 field, length_field, remainder, maxpacket;
        u64 addr, send_addr;
  
-@@ -3690,14 +3690,9 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
+@@ -3667,14 +3667,9 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
        send_addr = addr;
  
        if (xhci->quirks & XHCI_VLI_SS_BULK_OUT_BUG &&
@@ -40,7 +40,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
        }
  
        /* Queue the TRBs, even if they are zero-length */
-@@ -3712,7 +3707,7 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
+@@ -3689,7 +3684,7 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
                if (enqd_len + trb_buff_len > full_len)
                        trb_buff_len = full_len - enqd_len;
  
index dfae5566d9fd03acad9f42673634ea0a505ce3a7..1a6c372de25c6cd13da3c3af047379e273150e0d 100644 (file)
@@ -63,7 +63,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/20220227124713.39766-6-noral
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -5973,6 +5973,14 @@ T:      git git://anongit.freedesktop.org/drm
+@@ -5974,6 +5974,14 @@ T:      git git://anongit.freedesktop.org/drm
  F:    Documentation/devicetree/bindings/display/multi-inno,mi0283qt.txt
  F:    drivers/gpu/drm/tiny/mi0283qt.c
  
index 3668a821ef758f106d5be0d4124afa9ed2183672..1cae648358f8efc4e6b049fd45b465e0bded66f7 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Jakub Kicinski <kuba@kernel.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11782,6 +11782,14 @@ L:    netdev@vger.kernel.org
+@@ -11783,6 +11783,14 @@ L:    netdev@vger.kernel.org
  S:    Maintained
  F:    drivers/net/ethernet/mediatek/
  
index c0e29fa00fbf0eda20f2dbe7230eb9e6738d8042..2cebac1f8c6471b2a5a1ca406864689e08880736 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11894,6 +11894,7 @@ M:     Landen Chao <Landen.Chao@mediatek.com
+@@ -11895,6 +11895,7 @@ M:     Landen Chao <Landen.Chao@mediatek.com
  M:    DENG Qingfang <dqfext@gmail.com>
  L:    netdev@vger.kernel.org
  S:    Maintained
index 89dc30c7dffb7c341aac3ed04b3bc90cbb7050ed..889a13e0149bb416bcb045b44e738c66f82ee576 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11892,9 +11892,11 @@ MEDIATEK SWITCH DRIVER
+@@ -11893,9 +11893,11 @@ MEDIATEK SWITCH DRIVER
  M:    Sean Wang <sean.wang@mediatek.com>
  M:    Landen Chao <Landen.Chao@mediatek.com>
  M:    DENG Qingfang <dqfext@gmail.com>
index eb51b410b544413c2728fbf266f39ab21f6216f6..7eb097f86d02126c887cd07c2f6794f1cf5f92b5 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12693,6 +12693,7 @@ F:     include/uapi/linux/meye.h
+@@ -12694,6 +12694,7 @@ F:     include/uapi/linux/meye.h
  
  MOTORCOMM PHY DRIVER
  M:    Peter Geis <pgwipeout@gmail.com>
index 6ad9257d60e4e18c26986ca33eed482cf9d094b4..79fd479054ed932cd03185def3537688b8d183a5 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17958,6 +17958,11 @@ L:    netdev@vger.kernel.org
+@@ -17959,6 +17959,11 @@ L:    netdev@vger.kernel.org
  S:    Maintained
  F:    drivers/net/ethernet/dlink/sundance.c
  
index f7ea61626c506971a930800ec9f4522250b8ce14..24beeda0d2254e3889ede9efd8396b707340c0c7 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12357,6 +12357,14 @@ S:    Supported
+@@ -12358,6 +12358,14 @@ S:    Supported
  F:    Documentation/devicetree/bindings/mtd/atmel-nand.txt
  F:    drivers/mtd/nand/raw/atmel/*
  
index a44a5b6d89c8ca86524d9486f65c67d40f9e7a1e..4f1966db165054db035cfa167fcc8b344a894b67 100644 (file)
@@ -29,7 +29,7 @@ Subject: [PATCH] net/usb/qmi_wwan: add MeigLink modem support
  
  #define QUECTEL_VENDOR_ID                     0x2c7c
  /* These Quectel products use Quectel's vendor ID */
-@@ -1177,6 +1179,11 @@ static const struct usb_device_id option
+@@ -1179,6 +1181,11 @@ static const struct usb_device_id option
          .driver_info = ZLP },
        { USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96),
          .driver_info = RSVD(4) },
index 9fad4f62c61696eaf5948f7448efe6fd02cd6eeb..91654cc294c31f741cca8c16f601071c7a638f34 100644 (file)
@@ -91,7 +91,7 @@ Acked-by: Florian Fainelli <f.fainelli@gmail.com>
 
 --- a/drivers/irqchip/irq-bcm6345-l1.c
 +++ b/drivers/irqchip/irq-bcm6345-l1.c
-@@ -261,6 +261,9 @@ static int __init bcm6345_l1_init_one(st
+@@ -257,6 +257,9 @@ static int __init bcm6345_l1_init_one(st
        if (!cpu->map_base)
                return -ENOMEM;
  
@@ -101,7 +101,7 @@ Acked-by: Florian Fainelli <f.fainelli@gmail.com>
        for (i = 0; i < n_words; i++) {
                cpu->enable_cache[i] = 0;
                __raw_writel(0, cpu->map_base + reg_enable(intc, i));
-@@ -339,8 +342,7 @@ static int __init bcm6345_l1_of_init(str
+@@ -335,8 +338,7 @@ static int __init bcm6345_l1_of_init(str
        for_each_cpu(idx, &intc->cpumask) {
                struct bcm6345_l1_cpu *cpu = intc->cpus[idx];
  
index e8a69153500f8b922d0d142ee0c6b4c8b0a5cedf..445d050a7842d1291508c13817ff5345a89c51ac 100644 (file)
@@ -854,7 +854,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
 +};
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -7519,6 +7519,14 @@ F:      drivers/ptp/ptp_qoriq.c
+@@ -7520,6 +7520,14 @@ F:      drivers/ptp/ptp_qoriq.c
  F:    drivers/ptp/ptp_qoriq_debugfs.c
  F:    include/linux/fsl/ptp_qoriq.h
  
index 85e6b03a59eacb147cfda4b4d4101b60d0244ba5..1d8b509678e1875cf8fb0aca2708c6eb0a2aa23c 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11790,6 +11790,15 @@ S:    Maintained
+@@ -11791,6 +11791,15 @@ S:    Maintained
  F:    drivers/net/pcs/pcs-mtk-lynxi.c
  F:    include/linux/pcs/pcs-mtk-lynxi.h
  
index 44d3753b142d250389748b466d980ed1ce4435f2..79444e071e8443ef2dbe5345dfc4dca0810ca76b 100644 (file)
@@ -257,7 +257,7 @@ Signed-off-by: Wolfram Sang <wsa@kernel.org>
  
 --- a/drivers/i2c/busses/i2c-ibm_iic.c
 +++ b/drivers/i2c/busses/i2c-ibm_iic.c
-@@ -738,7 +738,7 @@ static int iic_probe(struct platform_dev
+@@ -736,7 +736,7 @@ static int iic_probe(struct platform_dev
        adap = &dev->adap;
        adap->dev.parent = &ofdev->dev;
        adap->dev.of_node = of_node_get(np);
index 242a6c1e00abba3f45f4e0eb7a1cf2dff74cb338..0b6891343d210655779194f58cdf277dbcdcbd0d 100644 (file)
@@ -16,7 +16,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -9056,6 +9056,22 @@ F:      include/net/nl802154.h
+@@ -9057,6 +9057,22 @@ F:      include/net/nl802154.h
  F:    net/ieee802154/
  F:    net/mac802154/
  
index dfe7ab28d73b9e3a3940c1d5d3c815dc8df0ec86..60db030647d94f36fffac0dd2e7330792400f60a 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -15895,6 +15895,13 @@ S:    Maintained
+@@ -15896,6 +15896,13 @@ S:    Maintained
  F:    include/sound/rt*.h
  F:    sound/soc/codecs/rt*