uboot-imx: pico-pi-imx7d: fix wrong make flags overriding
authorPetr Štetiar <ynezz@true.cz>
Tue, 12 Jul 2022 07:22:15 +0000 (09:22 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 12 Jul 2022 07:25:43 +0000 (09:25 +0200)
Buidbots are currently choking on the following compile error:

 In file included from tools/aisimage.c:9:
 include/image.h:1133:12: fatal error: openssl/evp.h: No such file or directory
  #  include <openssl/evp.h>
             ^~~~~~~~~~~~~~~
 compilation terminated.

This is caused by a complete overriding of make flags which are provided
correctly in `UBOOT_MAKE_FLAGS` variable, but currently overriden
instead of extended. This then leads to the usage of build host include
dirs, which are not available.

Fix it by extending `UBOOT_MAKE_FLAGS` variable like it was done in
commit 481339a04266 ("uboot-imx: fix wrong make flags overriding").

Fixes: 7094e6550336 ("uboot-imx: add support for TechNexion PICO-PI-IMX7D")
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/boot/uboot-imx/Makefile

index c23e48732b2384ec93912a8d310dfeb6d829fa25..ade26db768658758fdf747880d8a085c4d940d4c 100644 (file)
@@ -39,7 +39,7 @@ endef
 define U-Boot/pico-pi-imx7d
   NAME:=TechNexion PICO-PI-IMX7D
   UBOOT_IMAGE:=SPL u-boot-dtb.img
-  UBOOT_MAKE_FLAGS:=SPL u-boot-dtb.img
+  UBOOT_MAKE_FLAGS+=SPL u-boot-dtb.img
   BUILD_SUBTARGET:=cortexa7
   BUILD_DEVICES:=technexion_imx7d-pico-pi
 endef