devel/gdb: Disable libzstd explicitly
authorHannu Nyman <hannu.nyman@iki.fi>
Sun, 12 Nov 2023 18:34:45 +0000 (20:34 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 13 Nov 2023 14:41:03 +0000 (15:41 +0100)
New gdb has got libzstd support, and libzstd gets detected
at buildbot build. Explicitly disable it to avoid dependency.

Fixes: f79de8ec65 ("gdb: Update to 13.2")
Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
package/devel/gdb/Makefile

index 20a40eb8bbed63b1dd00c7a0143ac39436c43415..3efbce28f407725202174b4d291fad6e040c69c3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
 PKG_VERSION:=13.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
@@ -58,6 +58,7 @@ CONFIGURE_ARGS+= \
        --with-system-zlib \
        --without-expat \
        --without-lzma \
+       --without-zstd \
        --disable-unit-tests \
        --disable-ubsan \
        --disable-sim \