include: download.mk: correct tar argument order when packing checkouts
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 2 Dec 2012 18:35:47 +0000 (18:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 2 Dec 2012 18:35:47 +0000 (18:35 +0000)
GNU TAR v1.26 will fail with "no such file or directory" errors when the
output file does not immediately follow the -f switch.

SVN-Revision: 34460

include/download.mk

index 823ddf93f882c426cc9b9a36b3fe02be82f49a84..372db03194a5e41739031b1e2bc395e062f9658f 100644 (file)
@@ -29,8 +29,8 @@ $(strip \
 endef
 
 # code for creating tarballs from cvs/svn/git/bzr/hg/darcs checkouts - useful for mirror support
-dl_pack/bz2=$(TAR) cfj $(1) $(2)
-dl_pack/gz=$(TAR) cfz $(1) $(2)
+dl_pack/bz2=$(TAR) cjf $(1) $(2)
+dl_pack/gz=$(TAR) czf $(1) $(2)
 dl_pack/unknown=echo "ERROR: Unknown pack format for file $(1)"; false
 define dl_pack
        $(if $(dl_pack/$(call ext,$(1))),$(dl_pack/$(call ext,$(1))),$(dl_pack/unknown))