dnsmasq: bump to v2.88
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 17 Oct 2022 18:28:07 +0000 (19:28 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sun, 25 Dec 2022 15:07:36 +0000 (15:07 +0000)
Most relevant feature for openwrt in this release, supports dynamically
removing hosts from 'hostsdir' supplied host files.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/patches/100-remove-old-runtime-kernel-support.patch
package/network/services/dnsmasq/patches/200-ubus_dns.patch

index d4aa29845012d011783a394953b1dc72b16ec98e..65ef9da3a9a57e3c76fc7d97dbec9213aa6ecf59 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_UPSTREAM_VERSION:=2.87
+PKG_UPSTREAM_VERSION:=2.88
 PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
 PKG_SOURCE_URL:=https://thekelleys.org.uk/dnsmasq/
-PKG_HASH:=0228c0364a7f2356fd7e7f1549937cbf3099a78d3b2eb1ba5bb0c31e2b89de7a
+PKG_HASH:=23544deda10340c053bea6f15a93fed6ea7f5aaa85316bfc671ffa6d22fbc1b3
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
index b1b134a98c24407fa7c02c6f68fd9eac2010c724..76065375bdec987368cb7272d38fc7cf78287c84 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
  
 --- a/src/dnsmasq.h
 +++ b/src/dnsmasq.h
-@@ -1229,7 +1229,7 @@ extern struct daemon {
+@@ -1247,7 +1247,7 @@ extern struct daemon {
    int inotifyfd;
  #endif
  #if defined(HAVE_LINUX_NETWORK)
@@ -35,7 +35,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
  #elif defined(HAVE_BSD_NETWORK)
    int dhcp_raw_fd, dhcp_icmp_fd, routefd;
  #endif
-@@ -1422,9 +1422,6 @@ int read_write(int fd, unsigned char *pa
+@@ -1452,9 +1452,6 @@ int read_write(int fd, unsigned char *pa
  void close_fds(long max_fd, int spare1, int spare2, int spare3);
  int wildcard_match(const char* wildcard, const char* match);
  int wildcard_matchn(const char* wildcard, const char* match, int num);
@@ -140,7 +140,7 @@ Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
       my_syslog(LOG_ERR, _("failed to update ipset %s: %s"), setname, strerror(errno));
 --- a/src/util.c
 +++ b/src/util.c
-@@ -833,22 +833,3 @@ int wildcard_matchn(const char* wildcard
+@@ -855,22 +855,3 @@ int wildcard_matchn(const char* wildcard
  
    return (!num) || (*wildcard == *match);
  }
index c4cc1df207f96c7d0de23bee6d03434ca9a80b5d..f88763f94a0198eea4207c312d06abe377fab3e7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/dnsmasq.h
 +++ b/src/dnsmasq.h
-@@ -1598,14 +1598,26 @@ void emit_dbus_signal(int action, struct
+@@ -1630,14 +1630,26 @@ void emit_dbus_signal(int action, struct
  
  /* ubus.c */
  #ifdef HAVE_UBUS
        if (!ADD_RDLEN(header, p, qlen, rdlen))
         return 0; /* bad packet */
      }
-@@ -568,7 +637,7 @@ int extract_addresses(struct dns_header
+@@ -570,7 +639,7 @@ int extract_addresses(struct dns_header
    cache_start_insert();
  
    /* find_soa is needed for dns_doctor side effects, so don't call it lazily if there are any. */
    struct ubus_context *ubus = (struct ubus_context *)daemon->ubus;
 --- a/src/dnsmasq.c
 +++ b/src/dnsmasq.c
-@@ -1998,6 +1998,10 @@ static void check_dns_listeners(time_t n
+@@ -2003,6 +2003,10 @@ static void check_dns_listeners(time_t n
                  daemon->pipe_to_parent = pipefd[1];
                }