mediatek: add kmod-usb3 to default package set of the ZBT-Z8102AX
authorDaniel Golle <daniel@makrotopia.org>
Wed, 29 Nov 2023 21:10:37 +0000 (21:10 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 29 Nov 2023 21:13:32 +0000 (21:13 +0000)
Include XHCI USB drivers on the ZBT-Z8102AX router, the drivers are
required to be able to use the USB-connected M.2 slots for 4G/5G modems.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/filogic.mk

index a0a5f944a8f6988a95e64b22f95b98b8ad41e2c6..7c452ecb1e93ccad9e98d4eabe9f5b7859b04dda 100644 (file)
@@ -750,7 +750,7 @@ define Device/zbtlink_zbt-z8102ax
   DEVICE_MODEL := ZBT-Z8102AX
   DEVICE_DTS := mt7981b-zbtlink-zbt-z8102ax
   DEVICE_DTS_DIR := ../dts
-  DEVICE_PACKAGES := kmod-mt7981-firmware mt7981-wo-firmware kmod-usb-net-qmi-wwan kmod-usb-serial-option
+  DEVICE_PACKAGES := kmod-mt7981-firmware mt7981-wo-firmware kmod-usb3 kmod-usb-net-qmi-wwan kmod-usb-serial-option
   KERNEL_IN_UBI := 1
   UBINIZE_OPTS := -E 5
   BLOCKSIZE := 128k