bpf-headers: fix compilation with LLVM_IAS=1
authorHannu Nyman <hannu.nyman@iki.fi>
Sun, 28 May 2023 11:13:47 +0000 (14:13 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 10 Jun 2023 13:52:19 +0000 (15:52 +0200)
Linux 5.10.178 includes backported commits that break the compilation
of bpf-headers, as the compilation gets confused which assembler to use.
Caused by Linux upstream commits just before the .178 tag:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/log/?h=v5.10.178

2023-04-20 kbuild: check CONFIG_AS_IS_LLVM instead of LLVM_IAS
2023-04-20 kbuild: Switch to 'f' variants of integrated assembler flag
2023-04-20 kbuild: check the minimum assembler version in Kconfig

Explicitly use LLVM_IAS=1 to fix things.

Fixes #12748

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
package/kernel/bpf-headers/Makefile

index 0c1a02a0a1e86dc4d224832b91b96f5d8552dda8..4de0968ec13dd95fd2b902080614bd808b1080f4 100644 (file)
@@ -53,7 +53,7 @@ KERNEL_MAKE := \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARCH=$(BPF_KARCH) \
                CROSS_COMPILE=$(BPF_ARCH)-linux- \
-               LLVM=1 CC="$(CLANG)" LD="$(TARGET_CROSS)ld" \
+               LLVM=1 LLVM_IAS=1 CC="$(CLANG)" LD="$(TARGET_CROSS)ld" \
                HOSTCC="$(HOSTCC)" \
                HOSTCXX="$(HOSTCXX)" \
                HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib" \