iptables: iptables-mod-conntrack-extra: don't select kmod-ipt-raw
authorRafał Miłecki <rafal@milecki.pl>
Thu, 9 Feb 2023 12:29:37 +0000 (13:29 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Wed, 15 Feb 2023 13:28:08 +0000 (14:28 +0100)
Package kmod-ipt-raw enables CONFIG_IP_NF_RAW and packages
iptable_raw.ko

According to kernel's net/netfilter/Kconfig there are only 3 kernel
symbols that depend on the IP_NF_RAW:
1. NETFILTER_XT_TARGET_CT (xt_CT.ko)
2. NETFILTER_XT_TARGET_NOTRACK (unused symbol?!)
3. NETFILTER_XT_TARGET_TRACE (xt_TRACE.ko)

Now: iptables-mod-conntrack-extra selects kmod-ipt-conntrack-extra which
provides: xt_helper.ko nf_conncount.ko xt_connlimit.ko xt_connmark.ko
xt_recent.ko and xt_connbytes.ko (none of them seems to require
iptable_raw.ko).

It seems there is no explicit reason for iptables-mod-conntrack-extra to
require kmod-ipt-raw (iptables_raw.ko).

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/network/utils/iptables/Makefile

index dc57bb55d044bae6fa9e843354f4682533635f1f..e96cfa0b16b6164fa358c3aa92b384a8e05d792f 100644 (file)
@@ -150,7 +150,7 @@ Extra iptables nftables nft binaries.
 endef
 
 define Package/iptables-mod-conntrack-extra
-$(call Package/iptables/Module, +kmod-ipt-conntrack-extra +kmod-ipt-raw)
+$(call Package/iptables/Module, +kmod-ipt-conntrack-extra)
   TITLE:=Extra connection tracking extensions
 endef