kernel: Make kmod-phylink depend on kmod-libphy
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 30 May 2023 20:00:19 +0000 (22:00 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 31 May 2023 19:28:37 +0000 (21:28 +0200)
The CONFIG_PHYLINK Kconfig option in the kernel selects CONFIG_LIBPHY.
Add this dependency to fix the all kernel modules build on MIPS malta
and armvirt with kernel 6.1.

With kernel 5.15 mod-phylink and kmod-sfp are empty packages because
no OpenWrt kmod is selecting a module which needs sfp or phylink
support.

Fixes: #12758
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/netdevices.mk

index 934ba3c4f2d2edbcdbc00f1a1253e33404bc00a2..948902cf6365febfdc3dee8dbbd2b7a085e07350 100644 (file)
@@ -111,6 +111,7 @@ $(eval $(call KernelPackage,libphy))
 define KernelPackage/phylink
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Model for MAC to optional PHY connection
+  DEPENDS:=+kmod-libphy
   KCONFIG:=CONFIG_PHYLINK
   FILES:=$(LINUX_DIR)/drivers/net/phy/phylink.ko
   AUTOLOAD:=$(call AutoLoad,15,phylink,1)