util-linux: Use SYS_getrandom in randutils.c
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 May 2023 15:12:36 +0000 (17:12 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 19 May 2023 20:43:45 +0000 (22:43 +0200)
The getrandom syscall is not hanging at bootup any more if there is
not enough entropy. This was fixed upstream in 2018 in commit:
https://github.com/util-linux/util-linux/commit/a9cf659e0508c1f56813a7d74c64f67bbc962538

This OpenWrt patch is not needed any more.
This reverts commit e64463ebde55 ("util-linux: avoid using the getrandom syscall")

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/utils/util-linux/Makefile
package/utils/util-linux/patches/210-use-urandom.patch [deleted file]

index 8dab621390684f93145f61d87571ed947e2c8be9..704d4f11ec4eaa4f2fb472b3ef22941c8c77da43 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.39
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.39
diff --git a/package/utils/util-linux/patches/210-use-urandom.patch b/package/utils/util-linux/patches/210-use-urandom.patch
deleted file mode 100644 (file)
index 5817209..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/lib/randutils.c
-+++ b/lib/randutils.c
-@@ -26,6 +26,11 @@
- #define THREAD_LOCAL static
- #endif
-+/* force /dev/urandom to avoid hanging on early boot */
-+#undef HAVE_GETRANDOM
-+#undef SYS_getrandom
-+#undef __NR_getrandom
-+
- #ifdef HAVE_GETRANDOM
- # include <sys/random.h>
- #elif defined (__linux__)