ramips: add MT7615 wireless support for ELECOM WRC-GST devices
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Tue, 25 Jun 2019 13:20:44 +0000 (22:20 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 21 Jun 2020 18:52:30 +0000 (20:52 +0200)
ELECOM WRC-1900GST and WRC-2533GST have two MT7615 chips for 2.4/5 GHz
wireless.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
[WRC-1900GST]
Acked-by: NOGUCHI Hiroshi <drvlabo@gmail.com>
target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi
target/linux/ramips/image/mt7621.mk

index 03fe4675783d09c9616a3077e526317c26bee6a2..43f31cf2b67be65ed5e67f153e1f6f76ac83a637 100644 (file)
 
 &pcie {
        status = "okay";
-       /* WRC-xxxxGST has MT7615 for 2.4/5 GHz wifi, but it's not supported */
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+
+               led {
+                       led-sources = <0>;
+                       led-active-low;
+               };
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+
+               led {
+                       led-sources = <0>;
+                       led-active-low;
+               };
+       };
 };
 
 &xhci {
index ff4dca91b8e30106239179b5a2c222c086caff6d..848a0785fbcb7f74aef9a9d521581dde522d9b3b 100644 (file)
@@ -291,6 +291,7 @@ define Device/elecom_wrc-1900gst
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
        elecom-gst-factory WRC-1900GST 0.00
+  DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
 endef
 TARGET_DEVICES += elecom_wrc-1900gst
 
@@ -302,6 +303,7 @@ define Device/elecom_wrc-2533gst
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
        elecom-gst-factory WRC-2533GST 0.00
+  DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
 endef
 TARGET_DEVICES += elecom_wrc-2533gst