kernel: add TSL4531 ambient light sensor driver
authorHartmut Knaack <knaack.h@gmx.de>
Mon, 10 Sep 2018 23:33:36 +0000 (01:33 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 22 Sep 2018 19:20:55 +0000 (21:20 +0200)
Add support for the TAOS TSL4531x family of ambient light sensors using
the I2C bus.

Signed-off-by: Hartmut Knaack <knaack.h@gmx.de>
package/kernel/linux/modules/iio.mk

index a1410170db1b4b5d37fdb4a5c18adf26f781738b..d0c2c365caf67a0a493c45dc614645d03a7b47f0 100644 (file)
@@ -155,3 +155,21 @@ define KernelPackage/iio-htu21/description
 endef
 
 $(eval $(call KernelPackage,iio-htu21))
+
+
+define KernelPackage/iio-tsl4531
+  SUBMENU:=$(IIO_MENU)
+  DEPENDS:=+kmod-i2c-core +kmod-iio-core
+  TITLE:=TAOS TSL4531 ambient light sensor
+  KCONFIG:= CONFIG_TSL4531
+  FILES:=$(LINUX_DIR)/drivers/iio/light/tsl4531.ko
+  AUTOLOAD:=$(call AutoLoad,56,tsl4531)
+endef
+
+define KernelPackage/iio-tsl4531/description
+ Support for TAOS TSL4531x family of ambient light sensors
+ connected via I2C. Following models are usable:
+ TSL45311, TSL45313, TSL45315, TSL45317.
+endef
+
+$(eval $(call KernelPackage,iio-tsl4531))