ipq40xx: wpj428: switch to zimage to fit kernel partition
authorLeon M. Busch-George <leon@georgemail.eu>
Mon, 16 Oct 2023 17:41:21 +0000 (19:41 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 20 Oct 2023 16:13:57 +0000 (18:13 +0200)
Like with some other ipq40xx devices, the kernel image size for the WPJ428
is limited in stock u-boot. For that reason, the current release doesn't
include an image for the board.
By switching to the zImage format, the kernel image size is reduced which
re-enables the build process. The image boots and behaved normally through
a few days of testing.

Before the switch to kernel version 6.1, it was possible to reduce the
image size by enough when disabling UBIFS and its otherwise unneeded
dependencies.

Signed-off-by: Leon M. Busch-George <leon@georgemail.eu>
target/linux/ipq40xx/image/generic.mk

index 6581d81c00eb1d77bbe773a42d7cd74d3f64bcbc..d79fda3156a01b259b064d38f0ea09e54b4f7708 100644 (file)
@@ -354,7 +354,7 @@ endef
 #TARGET_DEVICES += compex_wpj419
 
 define Device/compex_wpj428
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        DEVICE_VENDOR := Compex
        DEVICE_MODEL := WPJ428
        SOC := qcom-ipq4028