build: prereq: add support for Python 3.8
authorThomas Weißschuh <thomas@t-8ch.de>
Thu, 14 Nov 2019 15:41:10 +0000 (16:41 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 14 Nov 2019 21:53:31 +0000 (22:53 +0100)
Add support for Python 3.8 which was released Oct. 14, 2019.

Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
[added missing commit description, simplified version check]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/prereq-build.mk

index d73f0040c357dc1b35ee41dee2f0f5a73bdbc712..a711ae33f7edd9d5ec494fc4d0e0e6a363a7ed85 100644 (file)
@@ -144,12 +144,14 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
 $(eval $(call CleanupPython2))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.5, \
+       python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
        python3.5 -V 2>&1 | grep 'Python 3', \
        python3 -V 2>&1 | grep -E 'Python 3\.[5-9]\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.5, \
+       python3.8 -V 2>&1 | grep 'Python 3', \
        python3.7 -V 2>&1 | grep 'Python 3', \
        python3.6 -V 2>&1 | grep 'Python 3', \
        python3.5 -V 2>&1 | grep 'Python 3', \