kernel: modules/lib-lz4: add lz4hc_compress
authorTony Butler <spudz76@gmail.com>
Mon, 28 Nov 2022 03:14:48 +0000 (19:14 -0800)
committerTony Butler <spudz76@gmail.com>
Sun, 11 Dec 2022 17:32:53 +0000 (09:32 -0800)
enable option `CONFIG_CRYPTO_LZ4HC` to match default kernel config

this only adds the `lz4hc_compress` module, and has no effect on the
`lz4_decompress` module which already supports any flavor

Signed-off-by: Tony Butler <spudz76@gmail.com>
package/kernel/linux/modules/lib.mk
package/kernel/linux/modules/other.mk
target/linux/generic/config-5.15

index 81ceb1f76ce036e9fe47d212f7f20fb5858d2367..d4d44ad8f0ac87bea4f488040dbb4556547e25b9 100644 (file)
@@ -152,13 +152,15 @@ define KernelPackage/lib-lz4
   DEPENDS:=+kmod-crypto-acompress
   KCONFIG:= \
        CONFIG_CRYPTO_LZ4 \
+       CONFIG_CRYPTO_LZ4HC \
        CONFIG_LZ4_COMPRESS \
        CONFIG_LZ4_DECOMPRESS
   FILES:= \
        $(LINUX_DIR)/crypto/lz4.ko \
        $(LINUX_DIR)/lib/lz4/lz4_compress.ko \
+       $(LINUX_DIR)/lib/lz4/lz4hc_compress.ko \
        $(LINUX_DIR)/lib/lz4/lz4_decompress.ko
-  AUTOLOAD:=$(call AutoProbe,lz4 lz4_compress lz4_decompress)
+  AUTOLOAD:=$(call AutoProbe,lz4 lz4_compress lz4hc_compress lz4_decompress)
 endef
 
 define KernelPackage/lib-lz4/description
index 58dd2d6c25f161e6997d91902b5d73d30c07028e..c5f944ed3194b595680451f9c3a5ef70e0c56e18 100644 (file)
@@ -1010,6 +1010,10 @@ define KernelPackage/zram/config
             bool "lz4"
             select PACKAGE_kmod-lib-lz4
 
+  config ZRAM_DEF_COMP_LZ4HC
+            bool "lz4-hc"
+            select PACKAGE_kmod-lib-lz4hc
+
   config ZRAM_DEF_COMP_ZSTD
             bool "zstd"
             select PACKAGE_kmod-lib-zstd
index b3541ab95bf1ed0cdc4b49ab54679b4d2251e496..52aba2fa0e630e53579f49eb55fa4ae0fb467bd0 100644 (file)
@@ -7547,6 +7547,7 @@ CONFIG_ZONE_DMA=y
 # CONFIG_ZPOOL is not set
 # CONFIG_ZRAM is not set
 # CONFIG_ZRAM_DEF_COMP_LZ4 is not set
+# CONFIG_ZRAM_DEF_COMP_LZ4HC is not set
 # CONFIG_ZRAM_DEF_COMP_LZO is not set
 # CONFIG_ZRAM_DEF_COMP_LZORLE is not set
 # CONFIG_ZRAM_DEF_COMP_ZSTD is not set