firmware-utils: package oseama
authorRafał Miłecki <rafal@milecki.pl>
Mon, 22 May 2023 08:31:34 +0000 (10:31 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Mon, 29 May 2023 10:22:38 +0000 (12:22 +0200)
It's required by bcm53xx. This allows dropping separated oseama package
and avoids some code duplication.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/utils/firmware-utils/Makefile
package/utils/oseama/Makefile [deleted file]
package/utils/oseama/src/Makefile [deleted file]
package/utils/oseama/src/md5.c [deleted file]
package/utils/oseama/src/md5.h [deleted file]
package/utils/oseama/src/oseama.c [deleted file]

index 78cbea4bd1c3bbcbcc1412f7b483a90c96351bbc..f49cca01bbc32423ef466442ded5b13adc54d8bf 100644 (file)
@@ -21,6 +21,13 @@ define Package/default
   DEPENDS:=$(2)
 endef
 
+Package/oseama = $(call Package/default,oseama,@TARGET_bcm53xx)
+
+define Package/oseama/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/oseama $(1)/usr/bin/
+endef
+
 Package/otrx = $(call Package/default,otrx,@(TARGET_bcm47xx||TARGET_bcm53xx))
 
 define Package/otrx/install
@@ -28,4 +35,5 @@ define Package/otrx/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/otrx $(1)/usr/bin/
 endef
 
+$(eval $(call BuildPackage,oseama))
 $(eval $(call BuildPackage,otrx))
diff --git a/package/utils/oseama/Makefile b/package/utils/oseama/Makefile
deleted file mode 100644 (file)
index 7d9303b..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-# Copyright (C) 2016 Rafał Miłecki <zajec5@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=oseama
-PKG_RELEASE:=1
-
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/oseama
-  SECTION:=utils
-  CATEGORY:=Base system
-  TITLE:=Utility for handling Seama firmware images
-  MAINTAINER:=Rafał Miłecki <zajec5@gmail.com>
-  DEPENDS:=@TARGET_bcm53xx
-endef
-
-define Package/oseama/description
- This package contains an utility that allows handling Seama images.
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS) -Wall"
-endef
-
-define Package/oseama/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/oseama $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,oseama))
diff --git a/package/utils/oseama/src/Makefile b/package/utils/oseama/src/Makefile
deleted file mode 100644 (file)
index ca35e6e..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-all: oseama
-
-oseama:
-       $(CC) $(CFLAGS) -Wall oseama.c md5.c -o $@ $^
-
-clean:
-       rm -f oseama
diff --git a/package/utils/oseama/src/md5.c b/package/utils/oseama/src/md5.c
deleted file mode 100644 (file)
index 52d96ac..0000000
+++ /dev/null
@@ -1,296 +0,0 @@
-/*
- * This is an OpenSSL-compatible implementation of the RSA Data Security, Inc.
- * MD5 Message-Digest Algorithm (RFC 1321).
- *
- * Homepage:
- * http://openwall.info/wiki/people/solar/software/public-domain-source-code/md5
- *
- * Author:
- * Alexander Peslyak, better known as Solar Designer <solar at openwall.com>
- *
- * This software was written by Alexander Peslyak in 2001.  No copyright is
- * claimed, and the software is hereby placed in the public domain.
- * In case this attempt to disclaim copyright and place the software in the
- * public domain is deemed null and void, then the software is
- * Copyright (c) 2001 Alexander Peslyak and it is hereby released to the
- * general public under the following terms:
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted.
- *
- * There's ABSOLUTELY NO WARRANTY, express or implied.
- *
- * (This is a heavily cut-down "BSD license".)
- *
- * This differs from Colin Plumb's older public domain implementation in that
- * no exactly 32-bit integer data type is required (any 32-bit or wider
- * unsigned integer data type will do), there's no compile-time endianness
- * configuration, and the function prototypes match OpenSSL's.  No code from
- * Colin Plumb's implementation has been reused; this comment merely compares
- * the properties of the two independent implementations.
- *
- * The primary goals of this implementation are portability and ease of use.
- * It is meant to be fast, but not as fast as possible.  Some known
- * optimizations are not included to reduce source code size and avoid
- * compile-time configuration.
- */
-
-#ifndef HAVE_OPENSSL
-
-#include <string.h>
-
-#include "md5.h"
-
-/*
- * The basic MD5 functions.
- *
- * F and G are optimized compared to their RFC 1321 definitions for
- * architectures that lack an AND-NOT instruction, just like in Colin Plumb's
- * implementation.
- */
-#define F(x, y, z)                     ((z) ^ ((x) & ((y) ^ (z))))
-#define G(x, y, z)                     ((y) ^ ((z) & ((x) ^ (y))))
-#define H(x, y, z)                     (((x) ^ (y)) ^ (z))
-#define H2(x, y, z)                    ((x) ^ ((y) ^ (z)))
-#define I(x, y, z)                     ((y) ^ ((x) | ~(z)))
-
-/*
- * The MD5 transformation for all four rounds.
- */
-#define STEP(f, a, b, c, d, x, t, s) \
-       (a) += f((b), (c), (d)) + (x) + (t); \
-       (a) = (((a) << (s)) | (((a) & 0xffffffff) >> (32 - (s)))); \
-       (a) += (b);
-
-/*
- * SET reads 4 input bytes in little-endian byte order and stores them
- * in a properly aligned word in host byte order.
- *
- * The check for little-endian architectures that tolerate unaligned
- * memory accesses is just an optimization.  Nothing will break if it
- * doesn't work.
- */
-#if defined(__i386__) || defined(__x86_64__) || defined(__vax__)
-#define SET(n) \
-       (*(MD5_u32plus *)&ptr[(n) * 4])
-#define GET(n) \
-       SET(n)
-#else
-#define SET(n) \
-       (ctx->block[(n)] = \
-       (MD5_u32plus)ptr[(n) * 4] | \
-       ((MD5_u32plus)ptr[(n) * 4 + 1] << 8) | \
-       ((MD5_u32plus)ptr[(n) * 4 + 2] << 16) | \
-       ((MD5_u32plus)ptr[(n) * 4 + 3] << 24))
-#define GET(n) \
-       (ctx->block[(n)])
-#endif
-
-/*
- * This processes one or more 64-byte data blocks, but does NOT update
- * the bit counters.  There are no alignment requirements.
- */
-static const void *body(MD5_CTX *ctx, const void *data, unsigned long size)
-{
-       const unsigned char *ptr;
-       MD5_u32plus a, b, c, d;
-       MD5_u32plus saved_a, saved_b, saved_c, saved_d;
-
-       ptr = (const unsigned char *)data;
-
-       a = ctx->a;
-       b = ctx->b;
-       c = ctx->c;
-       d = ctx->d;
-
-       do {
-               saved_a = a;
-               saved_b = b;
-               saved_c = c;
-               saved_d = d;
-
-/* Round 1 */
-               STEP(F, a, b, c, d, SET(0), 0xd76aa478, 7)
-               STEP(F, d, a, b, c, SET(1), 0xe8c7b756, 12)
-               STEP(F, c, d, a, b, SET(2), 0x242070db, 17)
-               STEP(F, b, c, d, a, SET(3), 0xc1bdceee, 22)
-               STEP(F, a, b, c, d, SET(4), 0xf57c0faf, 7)
-               STEP(F, d, a, b, c, SET(5), 0x4787c62a, 12)
-               STEP(F, c, d, a, b, SET(6), 0xa8304613, 17)
-               STEP(F, b, c, d, a, SET(7), 0xfd469501, 22)
-               STEP(F, a, b, c, d, SET(8), 0x698098d8, 7)
-               STEP(F, d, a, b, c, SET(9), 0x8b44f7af, 12)
-               STEP(F, c, d, a, b, SET(10), 0xffff5bb1, 17)
-               STEP(F, b, c, d, a, SET(11), 0x895cd7be, 22)
-               STEP(F, a, b, c, d, SET(12), 0x6b901122, 7)
-               STEP(F, d, a, b, c, SET(13), 0xfd987193, 12)
-               STEP(F, c, d, a, b, SET(14), 0xa679438e, 17)
-               STEP(F, b, c, d, a, SET(15), 0x49b40821, 22)
-
-/* Round 2 */
-               STEP(G, a, b, c, d, GET(1), 0xf61e2562, 5)
-               STEP(G, d, a, b, c, GET(6), 0xc040b340, 9)
-               STEP(G, c, d, a, b, GET(11), 0x265e5a51, 14)
-               STEP(G, b, c, d, a, GET(0), 0xe9b6c7aa, 20)
-               STEP(G, a, b, c, d, GET(5), 0xd62f105d, 5)
-               STEP(G, d, a, b, c, GET(10), 0x02441453, 9)
-               STEP(G, c, d, a, b, GET(15), 0xd8a1e681, 14)
-               STEP(G, b, c, d, a, GET(4), 0xe7d3fbc8, 20)
-               STEP(G, a, b, c, d, GET(9), 0x21e1cde6, 5)
-               STEP(G, d, a, b, c, GET(14), 0xc33707d6, 9)
-               STEP(G, c, d, a, b, GET(3), 0xf4d50d87, 14)
-               STEP(G, b, c, d, a, GET(8), 0x455a14ed, 20)
-               STEP(G, a, b, c, d, GET(13), 0xa9e3e905, 5)
-               STEP(G, d, a, b, c, GET(2), 0xfcefa3f8, 9)
-               STEP(G, c, d, a, b, GET(7), 0x676f02d9, 14)
-               STEP(G, b, c, d, a, GET(12), 0x8d2a4c8a, 20)
-
-/* Round 3 */
-               STEP(H, a, b, c, d, GET(5), 0xfffa3942, 4)
-               STEP(H2, d, a, b, c, GET(8), 0x8771f681, 11)
-               STEP(H, c, d, a, b, GET(11), 0x6d9d6122, 16)
-               STEP(H2, b, c, d, a, GET(14), 0xfde5380c, 23)
-               STEP(H, a, b, c, d, GET(1), 0xa4beea44, 4)
-               STEP(H2, d, a, b, c, GET(4), 0x4bdecfa9, 11)
-               STEP(H, c, d, a, b, GET(7), 0xf6bb4b60, 16)
-               STEP(H2, b, c, d, a, GET(10), 0xbebfbc70, 23)
-               STEP(H, a, b, c, d, GET(13), 0x289b7ec6, 4)
-               STEP(H2, d, a, b, c, GET(0), 0xeaa127fa, 11)
-               STEP(H, c, d, a, b, GET(3), 0xd4ef3085, 16)
-               STEP(H2, b, c, d, a, GET(6), 0x04881d05, 23)
-               STEP(H, a, b, c, d, GET(9), 0xd9d4d039, 4)
-               STEP(H2, d, a, b, c, GET(12), 0xe6db99e5, 11)
-               STEP(H, c, d, a, b, GET(15), 0x1fa27cf8, 16)
-               STEP(H2, b, c, d, a, GET(2), 0xc4ac5665, 23)
-
-/* Round 4 */
-               STEP(I, a, b, c, d, GET(0), 0xf4292244, 6)
-               STEP(I, d, a, b, c, GET(7), 0x432aff97, 10)
-               STEP(I, c, d, a, b, GET(14), 0xab9423a7, 15)
-               STEP(I, b, c, d, a, GET(5), 0xfc93a039, 21)
-               STEP(I, a, b, c, d, GET(12), 0x655b59c3, 6)
-               STEP(I, d, a, b, c, GET(3), 0x8f0ccc92, 10)
-               STEP(I, c, d, a, b, GET(10), 0xffeff47d, 15)
-               STEP(I, b, c, d, a, GET(1), 0x85845dd1, 21)
-               STEP(I, a, b, c, d, GET(8), 0x6fa87e4f, 6)
-               STEP(I, d, a, b, c, GET(15), 0xfe2ce6e0, 10)
-               STEP(I, c, d, a, b, GET(6), 0xa3014314, 15)
-               STEP(I, b, c, d, a, GET(13), 0x4e0811a1, 21)
-               STEP(I, a, b, c, d, GET(4), 0xf7537e82, 6)
-               STEP(I, d, a, b, c, GET(11), 0xbd3af235, 10)
-               STEP(I, c, d, a, b, GET(2), 0x2ad7d2bb, 15)
-               STEP(I, b, c, d, a, GET(9), 0xeb86d391, 21)
-
-               a += saved_a;
-               b += saved_b;
-               c += saved_c;
-               d += saved_d;
-
-               ptr += 64;
-       } while (size -= 64);
-
-       ctx->a = a;
-       ctx->b = b;
-       ctx->c = c;
-       ctx->d = d;
-
-       return ptr;
-}
-
-void MD5_Init(MD5_CTX *ctx)
-{
-       ctx->a = 0x67452301;
-       ctx->b = 0xefcdab89;
-       ctx->c = 0x98badcfe;
-       ctx->d = 0x10325476;
-
-       ctx->lo = 0;
-       ctx->hi = 0;
-}
-
-void MD5_Update(MD5_CTX *ctx, const void *data, unsigned long size)
-{
-       MD5_u32plus saved_lo;
-       unsigned long used, available;
-
-       saved_lo = ctx->lo;
-       if ((ctx->lo = (saved_lo + size) & 0x1fffffff) < saved_lo)
-               ctx->hi++;
-       ctx->hi += size >> 29;
-
-       used = saved_lo & 0x3f;
-
-       if (used) {
-               available = 64 - used;
-
-               if (size < available) {
-                       memcpy(&ctx->buffer[used], data, size);
-                       return;
-               }
-
-               memcpy(&ctx->buffer[used], data, available);
-               data = (const unsigned char *)data + available;
-               size -= available;
-               body(ctx, ctx->buffer, 64);
-       }
-
-       if (size >= 64) {
-               data = body(ctx, data, size & ~(unsigned long)0x3f);
-               size &= 0x3f;
-       }
-
-       memcpy(ctx->buffer, data, size);
-}
-
-void MD5_Final(unsigned char *result, MD5_CTX *ctx)
-{
-       unsigned long used, available;
-
-       used = ctx->lo & 0x3f;
-
-       ctx->buffer[used++] = 0x80;
-
-       available = 64 - used;
-
-       if (available < 8) {
-               memset(&ctx->buffer[used], 0, available);
-               body(ctx, ctx->buffer, 64);
-               used = 0;
-               available = 64;
-       }
-
-       memset(&ctx->buffer[used], 0, available - 8);
-
-       ctx->lo <<= 3;
-       ctx->buffer[56] = ctx->lo;
-       ctx->buffer[57] = ctx->lo >> 8;
-       ctx->buffer[58] = ctx->lo >> 16;
-       ctx->buffer[59] = ctx->lo >> 24;
-       ctx->buffer[60] = ctx->hi;
-       ctx->buffer[61] = ctx->hi >> 8;
-       ctx->buffer[62] = ctx->hi >> 16;
-       ctx->buffer[63] = ctx->hi >> 24;
-
-       body(ctx, ctx->buffer, 64);
-
-       result[0] = ctx->a;
-       result[1] = ctx->a >> 8;
-       result[2] = ctx->a >> 16;
-       result[3] = ctx->a >> 24;
-       result[4] = ctx->b;
-       result[5] = ctx->b >> 8;
-       result[6] = ctx->b >> 16;
-       result[7] = ctx->b >> 24;
-       result[8] = ctx->c;
-       result[9] = ctx->c >> 8;
-       result[10] = ctx->c >> 16;
-       result[11] = ctx->c >> 24;
-       result[12] = ctx->d;
-       result[13] = ctx->d >> 8;
-       result[14] = ctx->d >> 16;
-       result[15] = ctx->d >> 24;
-
-       memset(ctx, 0, sizeof(*ctx));
-}
-
-#endif
diff --git a/package/utils/oseama/src/md5.h b/package/utils/oseama/src/md5.h
deleted file mode 100644 (file)
index 2da44bf..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-/*
- * This is an OpenSSL-compatible implementation of the RSA Data Security, Inc.
- * MD5 Message-Digest Algorithm (RFC 1321).
- *
- * Homepage:
- * http://openwall.info/wiki/people/solar/software/public-domain-source-code/md5
- *
- * Author:
- * Alexander Peslyak, better known as Solar Designer <solar at openwall.com>
- *
- * This software was written by Alexander Peslyak in 2001.  No copyright is
- * claimed, and the software is hereby placed in the public domain.
- * In case this attempt to disclaim copyright and place the software in the
- * public domain is deemed null and void, then the software is
- * Copyright (c) 2001 Alexander Peslyak and it is hereby released to the
- * general public under the following terms:
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted.
- *
- * There's ABSOLUTELY NO WARRANTY, express or implied.
- *
- * See md5.c for more information.
- */
-
-#ifdef HAVE_OPENSSL
-#include <openssl/md5.h>
-#elif !defined(_MD5_H)
-#define _MD5_H
-
-/* Any 32-bit or wider unsigned integer data type will do */
-typedef unsigned int MD5_u32plus;
-
-typedef struct {
-       MD5_u32plus lo, hi;
-       MD5_u32plus a, b, c, d;
-       unsigned char buffer[64];
-       MD5_u32plus block[16];
-} MD5_CTX;
-
-extern void MD5_Init(MD5_CTX *ctx);
-extern void MD5_Update(MD5_CTX *ctx, const void *data, unsigned long size);
-extern void MD5_Final(unsigned char *result, MD5_CTX *ctx);
-
-#endif
diff --git a/package/utils/oseama/src/oseama.c b/package/utils/oseama/src/oseama.c
deleted file mode 100644 (file)
index 4434b11..0000000
+++ /dev/null
@@ -1,556 +0,0 @@
-/*
- * oseama
- *
- * Copyright (C) 2016 Rafał Miłecki <zajec5@gmail.com>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License as published by the Free
- * Software Foundation; either version 2 of the License, or (at your option)
- * any later version.
- */
-
-#include <byteswap.h>
-#include <endian.h>
-#include <errno.h>
-#include <stdint.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-#include <unistd.h>
-
-#include "md5.h"
-
-#if !defined(__BYTE_ORDER)
-#error "Unknown byte order"
-#endif
-
-#if __BYTE_ORDER == __BIG_ENDIAN
-#define cpu_to_be32(x) (x)
-#define be32_to_cpu(x) (x)
-#define cpu_to_be16(x) (x)
-#define be16_to_cpu(x) (x)
-#elif __BYTE_ORDER == __LITTLE_ENDIAN
-#define cpu_to_be32(x) bswap_32(x)
-#define be32_to_cpu(x) bswap_32(x)
-#define cpu_to_be16(x) bswap_16(x)
-#define be16_to_cpu(x) bswap_16(x)
-#else
-#error "Unsupported endianness"
-#endif
-
-#define SEAMA_MAGIC                    0x5ea3a417
-
-struct seama_seal_header {
-       uint32_t magic;
-       uint16_t reserved;
-       uint16_t metasize;
-       uint32_t imagesize;
-} __attribute__ ((packed));
-
-struct seama_entity_header {
-       uint32_t magic;
-       uint16_t reserved;
-       uint16_t metasize;
-       uint32_t imagesize;
-       uint8_t md5[16];
-} __attribute__ ((packed));
-
-char *seama_path;
-int entity_idx = -1;
-char *out_path;
-
-static inline size_t oseama_min(size_t x, size_t y) {
-       return x < y ? x : y;
-}
-
-/**************************************************
- * Info
- **************************************************/
-
-static void oseama_info_parse_options(int argc, char **argv) {
-       int c;
-
-       while ((c = getopt(argc, argv, "e:")) != -1) {
-               switch (c) {
-               case 'e':
-                       entity_idx = atoi(optarg);
-                       break;
-               }
-       }
-}
-
-static int oseama_info_entities(FILE *seama) {
-       struct seama_entity_header hdr;
-       size_t bytes, metasize, imagesize;
-       uint8_t buf[1024];
-       char *end, *tmp;
-       int i = 0;
-       int err = 0;
-
-       while ((bytes = fread(&hdr, 1, sizeof(hdr), seama)) == sizeof(hdr)) {
-               if (be32_to_cpu(hdr.magic) != SEAMA_MAGIC) {
-                       fprintf(stderr, "Invalid Seama magic: 0x%08x\n", be32_to_cpu(hdr.magic));
-                       err =  -EINVAL;
-                       goto err_out;
-               }
-               metasize = be16_to_cpu(hdr.metasize);
-               imagesize = be32_to_cpu(hdr.imagesize);
-
-               if (entity_idx >= 0 && i != entity_idx) {
-                       fseek(seama, metasize + imagesize, SEEK_CUR);
-                       i++;
-                       continue;
-               }
-
-               if (metasize >= sizeof(buf)) {
-                       fprintf(stderr, "Too small buffer (%zu B) to read all meta info (%zd B)\n", sizeof(buf), metasize);
-                       err =  -EINVAL;
-                       goto err_out;
-               }
-
-               if (entity_idx < 0)
-                       printf("\n");
-               printf("Entity offset:\t%ld\n", ftell(seama) - sizeof(hdr));
-               printf("Entity size:\t%zd\n", sizeof(hdr) + metasize + imagesize);
-               printf("Meta size:\t%zd\n", metasize);
-               printf("Image size:\t%zd\n", imagesize);
-
-               bytes = fread(buf, 1, metasize, seama);
-               if (bytes != metasize) {
-                       fprintf(stderr, "Couldn't read %zd B of meta\n", metasize);
-                       err =  -EIO;
-                       goto err_out;
-               }
-
-               end = (char *)&buf[metasize - 1];
-               *end = '\0';
-               for (tmp = (char *)buf; tmp < end && strlen(tmp); tmp += strlen(tmp) + 1) {
-                       printf("Meta entry:\t%s\n", tmp);
-               }
-
-               fseek(seama, imagesize, SEEK_CUR);
-               i++;
-       }
-
-err_out:
-       return err;
-}
-
-static int oseama_info(int argc, char **argv) {
-       FILE *seama;
-       struct seama_seal_header hdr;
-       size_t bytes;
-       uint16_t metasize;
-       uint32_t imagesize;
-       uint8_t buf[1024];
-       int err = 0;
-
-       if (argc < 3) {
-               fprintf(stderr, "No Seama file passed\n");
-               err = -EINVAL;
-               goto out;
-       }
-       seama_path = argv[2];
-
-       optind = 3;
-       oseama_info_parse_options(argc, argv);
-
-       seama = fopen(seama_path, "r");
-       if (!seama) {
-               fprintf(stderr, "Couldn't open %s\n", seama_path);
-               err = -EACCES;
-               goto out;
-       }
-
-       bytes = fread(&hdr, 1, sizeof(hdr), seama);
-       if (bytes != sizeof(hdr)) {
-               fprintf(stderr, "Couldn't read %s header\n", seama_path);
-               err =  -EIO;
-               goto err_close;
-       }
-       metasize = be16_to_cpu(hdr.metasize);
-       imagesize = be32_to_cpu(hdr.imagesize);
-
-       if (be32_to_cpu(hdr.magic) != SEAMA_MAGIC) {
-               fprintf(stderr, "Invalid Seama magic: 0x%08x\n", be32_to_cpu(hdr.magic));
-               err =  -EINVAL;
-               goto err_close;
-       }
-
-       if (metasize >= sizeof(buf)) {
-               fprintf(stderr, "Too small buffer (%zu B) to read all meta info (%d B)\n", sizeof(buf), metasize);
-               err =  -EINVAL;
-               goto err_close;
-       }
-
-       if (imagesize) {
-               fprintf(stderr, "Invalid Seama image size: 0x%08x (should be 0)\n", imagesize);
-               err =  -EINVAL;
-               goto err_close;
-       }
-
-       bytes = fread(buf, 1, metasize, seama);
-       if (bytes != metasize) {
-               fprintf(stderr, "Couldn't read %d B of meta\n", metasize);
-               err =  -EIO;
-               goto err_close;
-       }
-
-       if (entity_idx < 0) {
-               char *end, *tmp;
-
-               printf("Meta size:\t%d\n", metasize);
-               printf("Image size:\t%d\n", imagesize);
-
-               end = (char *)&buf[metasize - 1];
-               *end = '\0';
-               for (tmp = (char *)buf; tmp < end && strlen(tmp); tmp += strlen(tmp) + 1) {
-                       printf("Meta entry:\t%s\n", tmp);
-               }
-       }
-
-       oseama_info_entities(seama);
-
-err_close:
-       fclose(seama);
-out:
-       return err;
-}
-
-/**************************************************
- * Create
- **************************************************/
-
-static ssize_t oseama_entity_append_file(FILE *seama, const char *in_path) {
-       FILE *in;
-       size_t bytes;
-       ssize_t length = 0;
-       uint8_t buf[128];
-
-       in = fopen(in_path, "r");
-       if (!in) {
-               fprintf(stderr, "Couldn't open %s\n", in_path);
-               return -EACCES;
-       }
-
-       while ((bytes = fread(buf, 1, sizeof(buf), in)) > 0) {
-               if (fwrite(buf, 1, bytes, seama) != bytes) {
-                       fprintf(stderr, "Couldn't write %zu B to %s\n", bytes, seama_path);
-                       length = -EIO;
-                       break;
-               }
-               length += bytes;
-       }
-
-       fclose(in);
-
-       return length;
-}
-
-static ssize_t oseama_entity_append_zeros(FILE *seama, size_t length) {
-       uint8_t *buf;
-
-       buf = malloc(length);
-       if (!buf)
-               return -ENOMEM;
-       memset(buf, 0, length);
-
-       if (fwrite(buf, 1, length, seama) != length) {
-               fprintf(stderr, "Couldn't write %zu B to %s\n", length, seama_path);
-               return -EIO;
-       }
-
-       return length;
-}
-
-static ssize_t oseama_entity_align(FILE *seama, size_t curr_offset, size_t alignment) {
-       if (curr_offset & (alignment - 1)) {
-               size_t length = alignment - (curr_offset % alignment);
-
-               return oseama_entity_append_zeros(seama, length);
-       }
-
-       return 0;
-}
-
-static int oseama_entity_write_hdr(FILE *seama, size_t metasize, size_t imagesize) {
-       struct seama_entity_header hdr = {};
-       uint8_t buf[128];
-       size_t length = imagesize;
-       size_t bytes;
-       MD5_CTX ctx;
-
-       fseek(seama, sizeof(hdr) + metasize, SEEK_SET);
-       MD5_Init(&ctx);
-       while ((bytes = fread(buf, 1, oseama_min(sizeof(buf), length), seama)) > 0) {
-               MD5_Update(&ctx, buf, bytes);
-               length -= bytes;
-       }
-       MD5_Final(hdr.md5, &ctx);
-
-       hdr.magic = cpu_to_be32(SEAMA_MAGIC);
-       hdr.metasize = cpu_to_be16(metasize);
-       hdr.imagesize = cpu_to_be32(imagesize);
-
-       fseek(seama, 0, SEEK_SET);
-       bytes = fwrite(&hdr, 1, sizeof(hdr), seama);
-       if (bytes != sizeof(hdr)) {
-               fprintf(stderr, "Couldn't write Seama entity header to %s\n", seama_path);
-               return -EIO;
-       }
-
-       return 0;
-}
-
-static int oseama_entity(int argc, char **argv) {
-       FILE *seama;
-       ssize_t sbytes;
-       size_t curr_offset = sizeof(struct seama_entity_header);
-       size_t metasize = 0, imagesize = 0;
-       int c;
-       int err = 0;
-
-       if (argc < 3) {
-               fprintf(stderr, "No Seama file passed\n");
-               err = -EINVAL;
-               goto out;
-       }
-       seama_path = argv[2];
-
-       seama = fopen(seama_path, "w+");
-       if (!seama) {
-               fprintf(stderr, "Couldn't open %s\n", seama_path);
-               err = -EACCES;
-               goto out;
-       }
-       fseek(seama, curr_offset, SEEK_SET);
-
-       optind = 3;
-       while ((c = getopt(argc, argv, "m:f:b:")) != -1) {
-               switch (c) {
-               case 'm':
-                       sbytes = fwrite(optarg, 1, strlen(optarg) + 1, seama);
-                       if (sbytes < 0) {
-                               fprintf(stderr, "Failed to write meta %s\n", optarg);
-                       } else {
-                               curr_offset += sbytes;
-                               metasize += sbytes;
-                       }
-
-                       sbytes = oseama_entity_align(seama, curr_offset, 4);
-                       if (sbytes < 0) {
-                               fprintf(stderr, "Failed to append zeros\n");
-                       } else {
-                               curr_offset += sbytes;
-                               metasize += sbytes;
-                       }
-
-                       break;
-               case 'f':
-               case 'b':
-                       break;
-               }
-       }
-
-       optind = 3;
-       while ((c = getopt(argc, argv, "m:f:b:")) != -1) {
-               switch (c) {
-               case 'm':
-                       break;
-               case 'f':
-                       sbytes = oseama_entity_append_file(seama, optarg);
-                       if (sbytes < 0) {
-                               fprintf(stderr, "Failed to append file %s\n", optarg);
-                       } else {
-                               curr_offset += sbytes;
-                               imagesize += sbytes;
-                       }
-                       break;
-               case 'b':
-                       sbytes = strtol(optarg, NULL, 0) - curr_offset;
-                       if (sbytes < 0) {
-                               fprintf(stderr, "Current Seama entity length is 0x%zx, can't pad it with zeros to 0x%lx\n", curr_offset, strtol(optarg, NULL, 0));
-                       } else {
-                               sbytes = oseama_entity_append_zeros(seama, sbytes);
-                               if (sbytes < 0) {
-                                       fprintf(stderr, "Failed to append zeros\n");
-                               } else {
-                                       curr_offset += sbytes;
-                                       imagesize += sbytes;
-                               }
-                       }
-                       break;
-               }
-               if (err)
-                       break;
-       }
-
-       oseama_entity_write_hdr(seama, metasize, imagesize);
-
-       fclose(seama);
-out:
-       return err;
-}
-
-/**************************************************
- * Extract
- **************************************************/
-
-static void oseama_extract_parse_options(int argc, char **argv) {
-       int c;
-
-       while ((c = getopt(argc, argv, "e:o:")) != -1) {
-               switch (c) {
-               case 'e':
-                       entity_idx = atoi(optarg);
-                       break;
-               case 'o':
-                       out_path = optarg;
-                       break;
-               }
-       }
-}
-
-static int oseama_extract_entity(FILE *seama, FILE *out) {
-       struct seama_entity_header hdr;
-       size_t bytes, metasize, imagesize, length;
-       uint8_t buf[1024];
-       int i = 0;
-       int err = 0;
-
-       while ((bytes = fread(&hdr, 1, sizeof(hdr), seama)) == sizeof(hdr)) {
-               if (be32_to_cpu(hdr.magic) != SEAMA_MAGIC) {
-                       fprintf(stderr, "Invalid Seama magic: 0x%08x\n", be32_to_cpu(hdr.magic));
-                       err =  -EINVAL;
-                       break;
-               }
-               metasize = be16_to_cpu(hdr.metasize);
-               imagesize = be32_to_cpu(hdr.imagesize);
-
-               if (i != entity_idx) {
-                       fseek(seama, metasize + imagesize, SEEK_CUR);
-                       i++;
-                       continue;
-               }
-
-               fseek(seama, -sizeof(hdr), SEEK_CUR);
-
-               length = sizeof(hdr) + metasize + imagesize;
-               while ((bytes = fread(buf, 1, oseama_min(sizeof(buf), length), seama)) > 0) {
-                       if (fwrite(buf, 1, bytes, out) != bytes) {
-                               fprintf(stderr, "Couldn't write %zu B to %s\n", bytes, out_path);
-                               err = -EIO;
-                               break;
-                       }
-                       length -= bytes;
-               }
-
-               if (length) {
-                       fprintf(stderr, "Couldn't extract whole entity %d from %s (%zu B left)\n", entity_idx, seama_path, length);
-                       err = -EIO;
-                       break;
-               }
-
-               break;
-       }
-
-       return err;
-}
-
-static int oseama_extract(int argc, char **argv) {
-       FILE *seama;
-       FILE *out;
-       struct seama_seal_header hdr;
-       size_t bytes;
-       uint16_t metasize;
-       int err = 0;
-
-       if (argc < 3) {
-               fprintf(stderr, "No Seama file passed\n");
-               err = -EINVAL;
-               goto out;
-       }
-       seama_path = argv[2];
-
-       optind = 3;
-       oseama_extract_parse_options(argc, argv);
-       if (entity_idx < 0) {
-               fprintf(stderr, "No entity specified\n");
-               err = -EINVAL;
-               goto out;
-       } else if (!out_path) {
-               fprintf(stderr, "No output file specified\n");
-               err = -EINVAL;
-               goto out;
-       }
-
-       seama = fopen(seama_path, "r");
-       if (!seama) {
-               fprintf(stderr, "Couldn't open %s\n", seama_path);
-               err = -EACCES;
-               goto out;
-       }
-
-       out = fopen(out_path, "w");
-       if (!out) {
-               fprintf(stderr, "Couldn't open %s\n", out_path);
-               err = -EACCES;
-               goto err_close_seama;
-       }
-
-       bytes = fread(&hdr, 1, sizeof(hdr), seama);
-       if (bytes != sizeof(hdr)) {
-               fprintf(stderr, "Couldn't read %s header\n", seama_path);
-               err =  -EIO;
-               goto err_close_out;
-       }
-       metasize = be16_to_cpu(hdr.metasize);
-
-       fseek(seama, metasize, SEEK_CUR);
-
-       oseama_extract_entity(seama, out);
-
-err_close_out:
-       fclose(out);
-err_close_seama:
-       fclose(seama);
-out:
-       return err;
-}
-
-/**************************************************
- * Start
- **************************************************/
-
-static void usage() {
-       printf("Usage:\n");
-       printf("\n");
-       printf("Info about Seama seal (container):\n");
-       printf("\toseama info <file> [options]\n");
-       printf("\t-e\t\t\t\tprint info about specified entity only\n");
-       printf("\n");
-       printf("Create Seama entity:\n");
-       printf("\toseama entity <file> [options]\n");
-       printf("\t-m meta\t\t\t\tmeta into to put in header\n");
-       printf("\t-f file\t\t\t\tappend content from file\n");
-       printf("\t-b offset\t\t\tappend zeros till reaching absolute offset\n");
-       printf("\n");
-       printf("Extract from Seama seal (container):\n");
-       printf("\toseama extract <file> [options]\n");
-       printf("\t-e\t\t\t\tindex of entity to extract\n");
-       printf("\t-o file\t\t\t\toutput file\n");
-}
-
-int main(int argc, char **argv) {
-       if (argc > 1) {
-               if (!strcmp(argv[1], "info"))
-                       return oseama_info(argc, argv);
-               else if (!strcmp(argv[1], "entity"))
-                       return oseama_entity(argc, argv);
-               else if (!strcmp(argv[1], "extract"))
-                       return oseama_extract(argc, argv);
-       }
-
-       usage();
-       return 0;
-}