kernel: iscsi-initator: fix kernel config symbols
authorLucian Cristian <lucian.cristian@gmail.com>
Wed, 8 Jul 2020 19:49:57 +0000 (22:49 +0300)
committerPetr Štetiar <ynezz@true.cz>
Thu, 9 Jul 2020 08:28:40 +0000 (10:28 +0200)
Enable SCSI low-level drivers on targets that don't have it already in
order to fix following build failures on few platforms:

  .config:4739:warning: symbol value 'm' invalid for SCSI_LOWLEVEL
 * Restart config...
 * SCSI low-level drivers
 SCSI low-level drivers (SCSI_LOWLEVEL) [Y/n] (NEW) aborted!

Fixes: b88f8202c4ce ("kernel: add iscsi-initator support")
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
[commit subject and description facelift]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/linux/modules/block.mk

index faea5cc34ef745def17cf7a12c93230a22e0cead..fbd3c81911b3de40df8a2e66ed66dd2ea2f8101b 100644 (file)
@@ -276,9 +276,9 @@ define KernelPackage/iscsi-initiator
   DEPENDS:=+kmod-scsi-core +kmod-crypto-hash
   KCONFIG:= \
        CONFIG_INET \
-       CONFIG_SCSI_LOWLEVEL \
+       CONFIG_SCSI_LOWLEVEL=y \
        CONFIG_ISCSI_TCP \
-       CONFIG_SCSI_ISCSI_ATTRS
+       CONFIG_SCSI_ISCSI_ATTRS=y
   FILES:= \
        $(LINUX_DIR)/drivers/scsi/iscsi_tcp.ko \
        $(LINUX_DIR)/drivers/scsi/libiscsi.ko \