ath79: revert erroneous second addition of files for WNDR4300
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 2 Nov 2019 23:43:23 +0000 (00:43 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 2 Nov 2019 23:46:59 +0000 (00:46 +0100)
There are two recent commits stating to add support for Netgear
WNDR4300, where the second one seems to be just leftover from
an earlier patch having been rebased.

Since the first patch already provides support in the most recent
state, just revert the second one.

This reverts commit cd87272eb241b1ea7955c1631ad2bb8d38e9fae9.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/Makefile
target/linux/ath79/image/nand-netgear.mk [deleted file]

index b6ac83cdc16bb6d0da25a49a6fa7d4546966f435..24768ef5e0d6bf7ce027a8e0d9b012783b6ddaeb 100644 (file)
@@ -77,7 +77,6 @@ include ./generic-ubnt.mk
 endif
 ifeq ($(SUBTARGET),nand)
 include ./nand.mk
-include ./nand-netgear.mk
 endif
 ifeq ($(SUBTARGET),tiny)
 include ./tiny.mk
diff --git a/target/linux/ath79/image/nand-netgear.mk b/target/linux/ath79/image/nand-netgear.mk
deleted file mode 100644 (file)
index b25e6ec..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-include ./common-netgear.mk    # for netgear-uImage
-
-# (pad-offset 129 = 2 * uimage_header + 0xff)
-define Device/netgear_ath79_nand
-  DEVICE_VENDOR := NETGEAR
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
-  KERNEL_SIZE := 2048k
-  BLOCKSIZE := 128k
-  PAGESIZE := 2048
-  IMAGE_SIZE := 25600k
-  KERNEL := kernel-bin | append-dtb | lzma -d20 | \
-       pad-offset $$(KERNEL_SIZE) 129 | \
-       netgear-uImage lzma | append-string -e '\xff' | \
-       append-uImage-fakehdr filesystem $$(NETGEAR_KERNEL_MAGIC)
-  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | \
-       netgear-uImage lzma
-  IMAGES := ubi-sysupgrade.bin ubi-factory.img
-  IMAGE/ubi-factory.img := append-kernel | append-ubi | netgear-dni | \
-       check-size $$$$(IMAGE_SIZE)
-  IMAGE/ubi-sysupgrade.bin := sysupgrade-tar | append-metadata | \
-       check-size $$$$(IMAGE_SIZE)
-  UBINIZE_OPTS := -E 5
-endef
-
-define Device/netgear_wndr4300
-  ATH_SOC := ar9344
-  DEVICE_MODEL := WNDR4300
-  NETGEAR_KERNEL_MAGIC := 0x33373033
-  NETGEAR_BOARD_ID := WNDR4300
-  NETGEAR_HW_ID := 29763948+0+128+128+2x2+3x3
-  SUPPORTED_DEVICES += wndr4300
-  $(Device/netgear_ath79_nand)
-endef
-TARGET_DEVICES += netgear_wndr4300