Revert "tools/fakeroot: update to 1.30.1"
authorMichael Pratt <mcpratt@pm.me>
Fri, 20 Jan 2023 04:34:05 +0000 (23:34 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 12 Feb 2023 00:02:22 +0000 (01:02 +0100)
This reverts commit 52167feff8ae3fbd02be22dfe6021e7e9c79c599.

Fakeroot 1.30.1 broke building on certain hosts (32-bit archs).

As of 2023-01-10, this was apparently fixed in source code,
however, the version is still 1.30.1 (patch release),
so the old binaries are removed from the repository and replaced,
but the source provided by the repository remains the same.

Furthermore, there are some complicated issues blocking
the "testing" release from being bumped to a 1.30.x version.

Considering all of this, it would likely be better for this package
to follow the "testing" release instead of the "unstable" release,
which is still 1.29-1, so revert to that.

Link: https://bugs.debian.org/1023286
Link: https://tracker.debian.org/news/1407613/accepted-fakeroot-1301-11-source-into-unstable/
Link: https://qa.debian.org/excuses.php?package=fakeroot
Link: https://bugs.debian.org/1027803
Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/fakeroot/Makefile
tools/fakeroot/patches/600-macOS.patch

index 66ccbcb50d68227b76d4b29a34a5d432cd37e753..efd9227d1a907470455c5166c23d0662a0282cdb 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fakeroot
-PKG_VERSION:=1.30.1
+PKG_VERSION:=1.29
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=@DEBIAN/pool/main/f/fakeroot
-PKG_HASH:=32ebb1f421aca0db7141c32a8c104eb95d2b45c393058b9435fbf903dd2b6a75
+PKG_HASH:=8fbbafb780c9173e3ace4a04afbc1d900f337f3216883939f5c7db3431be7c20
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_LICENSE_FILES:=COPYING
 PKG_FIXUP:=autoreconf
index 5cfcc8128485a93fb9071a0eede157b63a8951f0..730367f07c7fadbd2f8fb66213cf36473da18535 100644 (file)
@@ -24,7 +24,7 @@
  #include <spawn.h>
 --- a/wrapfunc.inp
 +++ b/wrapfunc.inp
-@@ -50,9 +50,11 @@ getattrlist$UNIX2003;int;(const char *pa
+@@ -48,9 +48,11 @@ getattrlist$UNIX2003;int;(const char *pa
  #endif
  #endif
  #if MAC_OS_X_VERSION_MIN_REQUIRED >= MAC_OS_X_VERSION_10_5
@@ -36,7 +36,7 @@
  posix_spawn;int;(pid_t * __restrict pid, const char * __restrict path, const posix_spawn_file_actions_t *file_actions, const posix_spawnattr_t * __restrict attrp, char *const argv[ __restrict], char *const envp[ __restrict]);(pid, path, file_actions, attrp, argv, envp)
  posix_spawnp;int;(pid_t * __restrict pid, const char * __restrict path, const posix_spawn_file_actions_t *file_actions, const posix_spawnattr_t * __restrict attrp, char *const argv[ __restrict], char *const envp[ __restrict]);(pid, path, file_actions, attrp, argv, envp)
  #endif
-@@ -231,7 +233,7 @@ facl;int;(int fd, int cmd, int cnt, void
+@@ -229,7 +231,7 @@ facl;int;(int fd, int cmd, int cnt, void
  #ifdef HAVE_FTS_READ
  fts_read;FTSENT *;(FTS *ftsp);(ftsp)
  #ifdef __APPLE__
@@ -45,7 +45,7 @@
  fts_read$INODE64;FTSENT *;(FTS *ftsp);(ftsp)
  #endif
  #endif /* ifdef __APPLE__ */
-@@ -239,7 +241,7 @@ fts_read$INODE64;FTSENT *;(FTS *ftsp);(f
+@@ -237,7 +239,7 @@ fts_read$INODE64;FTSENT *;(FTS *ftsp);(f
  #ifdef HAVE_FTS_CHILDREN
  fts_children;FTSENT *;(FTS *ftsp, int options);(ftsp, options)
  #ifdef __APPLE__