Revert "image: update LZMA_XZ_OPTIONS with new squashfs4 tool"
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 12 Apr 2023 10:13:46 +0000 (12:13 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 12 Apr 2023 10:25:18 +0000 (12:25 +0200)
This reverts commit a33b97dcb1bd6e68f01c571e92ef02c3ab721523.

A new version of the squashfs4 tool patch reintroduced the -Xe option.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/image.mk

index ef242db96e554e92f57b66faed9f07256e77b1e7..b801ef993c310c1acafb4b635211e585dddeb588 100644 (file)
@@ -77,7 +77,7 @@ SQUASHFSOPT := -b $(SQUASHFS_BLOCKSIZE)
 SQUASHFSOPT += -p '/dev d 755 0 0' -p '/dev/console c 600 0 0 5 1'
 SQUASHFSOPT += $(if $(CONFIG_SELINUX),-xattrs,-no-xattrs)
 SQUASHFSCOMP := gzip
-LZMA_XZ_OPTIONS := -Xpreset extreme -Xlc 0 -Xlp 2 -Xpb 2
+LZMA_XZ_OPTIONS := -Xpreset 9 -Xe -Xlc 0 -Xlp 2 -Xpb 2
 ifeq ($(CONFIG_SQUASHFS_XZ),y)
   ifneq ($(filter arm x86 powerpc sparc,$(LINUX_KARCH)),)
     BCJ_FILTER:=-Xbcj $(LINUX_KARCH)