uqmi: Ignore wrong maybe-uninitialized and dangling-pointer error
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 19 Dec 2022 00:19:32 +0000 (01:19 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 8 Jan 2023 23:10:52 +0000 (00:10 +0100)
GCC 12.2.0 shows this false positive error message:
````
uqmi-2022-05-04-56cb2d40/dev.c: In function 'qmi_request_wait':
uqmi-2022-05-04-56cb2d40/dev.c:217:23: error: storing the address of local variable 'complete' in '*req.complete' [-Werror=dangling-pointer=]
  217 |         req->complete = &complete;
      |         ~~~~~~~~~~~~~~^~~~~~~~~~~
uqmi-2022-05-04-56cb2d40/dev.c:208:14: note: 'complete' declared here
  208 |         bool complete = false;
      |              ^~~~~~~~
uqmi-2022-05-04-56cb2d40/dev.c:208:14: note: 'req' declared here
cc1: all warnings being treated as errors
````

and this one:
````
In file included from uqmi-2022-05-04-56cb2d40/commands.c:28:
In function 'blobmsg_close_table',
    inlined from 'cmd_nas_get_cell_location_info_cb' at /home/haukeuqmi-2022-05-04-56cb2d40/commands-nas.c:897:4:
/usr/include/libubox/blobmsg.h:256:9: error: 'c' may be used uninitialized [-Werror=maybe-uninitialized]
  256 |         blob_nest_end(buf, cookie);
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from uqmi-2022-05-04-56cb2d40/commands.c:169:
uqmi-2022-05-04-56cb2d40/commands-nas.c: In function 'cmd_nas_get_cell_location_info_cb':
uqmi-2022-05-04-56cb2d40/commands-nas.c:713:15: note: 'c' was declared here
  713 |         void *c, *t, *cell, *freq;
      |               ^
cc1: all warnings being treated as errors
````

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/utils/uqmi/Makefile

index c4ca98012a0fbce04080ee6b7963b442e064ca1d..02265d400c1db33cc020f8150e1c9a37945097c6 100644 (file)
@@ -32,7 +32,11 @@ define Package/uqmi/description
 endef
 
 TARGET_CFLAGS += \
-       -I$(STAGING_DIR)/usr/include -ffunction-sections -fdata-sections
+       -I$(STAGING_DIR)/usr/include \
+       -ffunction-sections \
+       -fdata-sections \
+       -Wno-error=dangling-pointer \
+       -Wno-error=maybe-uninitialized
 
 TARGET_LDFLAGS += -Wl,--gc-sections