ipq40xx: add support for Mikrotik wAP R ac / LTE / LTE6
authorAlexander Couzens <lynxis@fe80.eu>
Sat, 12 Nov 2022 12:13:46 +0000 (12:13 +0000)
committerAlexander Couzens <lynxis@fe80.eu>
Sun, 27 Nov 2022 13:28:22 +0000 (13:28 +0000)
The Mikrotik wAP R AC is an outdoor, dual band, dual radio (802.11ac) AP
with a miniPCIe slot for a LTE modem.
The wAP R AC is similar to the wAP AC but with the miniPCIe slot.
The wAP R AC requires installing a LTE modem.
The wAP LTE and wAP LTE6 comes with a LTE modem installed.

See https://mikrotik.com/product/wap_r_ac for more info.

Specifications:
- SoC: Qualcomm Atheros IPQ4018
- CPU: 4x ARM Cortex A7
- RAM: 128MB
- Storage: 16MB NOR flash
- Wireless:
   - Built-in IPQ4018 (SoC) 802.11b/g/n 2x2:2, internal antenna
   - Built-in IPQ4018 (SoC) 802.11a/n/ac 2x2:2, internal antenna
- Ethernet: Built-in IPQ4018 (SoC, QCA8075) , 2x 1000/100/10 ports
  one with 802.3af/at PoE in
- 1x Mini PCI-E port (USB2)

Installation:
Boot the initramfs image via TFTP, then flash the sysupgrade image using
sysupgrade. Details at https://openwrt.org/toh/mikrotik/common.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/base-files/lib/preinit/05_set_iface_mac_ipq40xx.sh
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac-lte.dts [new file with mode: 0644]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dts
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dtsi [new file with mode: 0644]
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-r-ac.dts [new file with mode: 0644]
target/linux/ipq40xx/image/mikrotik.mk

index 24b59d6630cc7c91bb4d005c7f6039fb756b4d5c..74f39ef6de965a6c423122f660b1293a5a782bcd 100644 (file)
@@ -64,7 +64,9 @@ ipq40xx_setup_interfaces()
        mobipromo,cm520-79f)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
                ;;
-       mikrotik,wap-ac)
+       mikrotik,wap-ac|\
+       mikrotik,wap-ac-lte|\
+       mikrotik,wap-r-ac)
                ucidef_set_interface_lan "sw-eth1 sw-eth2"
                ;;
        netgear,rbr50|\
index 7498e1c71040e8dbb76f7742e6971da66f7c455c..7f41bdcfcc58c2af7bae07d6f1be1dcb8d145805 100644 (file)
@@ -113,7 +113,9 @@ case "$FIRMWARE" in
        mikrotik,hap-ac2 |\
        mikrotik,hap-ac3 |\
        mikrotik,hap-ac3-lte6-kit |\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac |\
+       mikrotik,wap-ac-lte |\
+       mikrotik,wap-r-ac)
                wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
                ( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0x0 0x2f20 ) || \
                ( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_0" 0x0 0x2f20 )
@@ -207,7 +209,9 @@ case "$FIRMWARE" in
        mikrotik,hap-ac3 |\
        mikrotik,hap-ac3-lte6-kit |\
        mikrotik,sxtsq-5-ac |\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac |\
+       mikrotik,wap-ac-lte |\
+       mikrotik,wap-r-ac)
                wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
                ( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0x8000 0x2f20 ) || \
                ( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_2" 0x0 0x2f20 )
@@ -243,7 +247,9 @@ case "$FIRMWARE" in
        mikrotik,hap-ac2 |\
        mikrotik,hap-ac3 |\
        mikrotik,hap-ac3-lte6-kit |\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac |\
+       mikrotik,wap-ac-lte |\
+       mikrotik,wap-r-ac)
                wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
                ( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0x2f20 0x2f20 ) || \
                ( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_0" 0x2f20 0x2f20 )
@@ -257,7 +263,9 @@ case "$FIRMWARE" in
        mikrotik,hap-ac3 |\
         mikrotik,hap-ac3-lte6-kit |\
        mikrotik,sxtsq-5-ac |\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac |\
+       mikrotik,wap-ac-lte |\
+       mikrotik,wap-r-ac)
                wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
                ( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0xaf20 0x2f20 ) || \
                ( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_2" 0x2f20 0x2f20 )
index ddfef1ab2d42b8d858efff17e50625742f840e49..ce0b55bb80915e9ad48bd127a5d5bf7ce2f8e596 100644 (file)
@@ -29,7 +29,9 @@ preinit_set_mac_address() {
                ip link set dev lan1 address $(macaddr_add "$base_mac" 1)
                ip link set dev eth0 address $(macaddr_setbit "$base_mac" 7)
                ;;
-       mikrotik,wap-ac)
+       mikrotik,wap-ac|\
+       mikrotik,wap-ac-lte|\
+       mikrotik,wap-r-ac)
                base_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
                ip link set dev sw-eth1 address "$base_mac"
                ip link set dev sw-eth2 address $(macaddr_add "$base_mac" 1)
index 6b8f62d73586abff417b4a75be47102aee58e5f9..12fa9699c572e92577d149a57401e0cbb3252661 100644 (file)
@@ -177,7 +177,9 @@ platform_do_upgrade() {
        mikrotik,hap-ac3-lte6-kit|\
        mikrotik,lhgg-60ad|\
        mikrotik,sxtsq-5-ac|\
-       mikrotik,wap-ac)
+       mikrotik,wap-ac|\
+       mikrotik,wap-ac-lte|\
+       mikrotik,wap-r-ac)
                [ "$(rootfs_type)" = "tmpfs" ] && mtd erase firmware
                default_do_upgrade "$1"
                ;;
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac-lte.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac-lte.dts
new file mode 100644 (file)
index 0000000..8ff18d9
--- /dev/null
@@ -0,0 +1,45 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/* Copyright (c) 2022, Alexander Couzens <lynxis@fe80.eu> */
+
+#include "qcom-ipq4018-wap-ac.dtsi"
+
+/ {
+       model = "MikroTik wAP ac LTE";
+       compatible = "mikrotik,wap-ac-lte";
+
+       soc {
+               tcsr@194b000 {
+                       /* select hostmode */
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+                       status = "okay";
+               };
+
+               usb3@8af8800 {
+                       status = "okay";
+
+                       dwc3@8a00000 {
+                               phys = <&usb3_hs_phy>;
+                               phy-names = "usb2-phy";
+                       };
+               };
+       };
+};
+
+&tlmm {
+       enable-usb-power {
+               gpio-hog;
+               gpios = <2 GPIO_ACTIVE_HIGH>;
+               output-high;
+               line-name = "enable USB power";
+       };
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb3 {
+       status = "okay";
+};
index ecbdfac15f81701a021301ec16f9af9aecf61be4..1bfcbf1e334553d72dd9b64a8ea89fbfe52bfce5 100644 (file)
@@ -1,218 +1,9 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 /* Copyright (c) 2020, Robert Marko <robimarko@gmail.com> */
 
-#include "qcom-ipq4019.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/soc/qcom,tcsr.h>
+#include "qcom-ipq4018-wap-ac.dtsi"
 
 / {
        model = "MikroTik wAP ac";
        compatible = "mikrotik,wap-ac";
-
-       memory {
-               device_type = "memory";
-               reg = <0x80000000 0x08000000>;
-       };
-
-       chosen {
-               stdout-path = "serial0:115200n8";
-       };
-
-       aliases {
-               led-boot = &led_user;
-               led-failsafe = &led_user;
-               led-running = &led_user;
-               led-upgrade = &led_user;
-       };
-
-       soc {
-               counter@4a1000 {
-                       compatible = "qcom,qca-gcnt";
-                       reg = <0x4a1000 0x4>;
-               };
-
-               tcsr@1949000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1949000 0x100>;
-                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
-               };
-
-               ess_tcsr@1953000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1953000 0x1000>;
-                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
-               };
-
-               tcsr@1957000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1957000 0x100>;
-                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               power {
-                       label = "blue:power";
-                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
-                       default-state = "keep";
-               };
-
-               led_user: user {
-                       label = "green:user";
-                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
-                       panic-indicator;
-               };
-       };
-};
-
-&prng {
-       status = "okay";
-};
-
-&tlmm {
-       serial_pins: serial_pinmux {
-               mux {
-                       pins = "gpio60", "gpio61";
-                       function = "blsp_uart0";
-                       bias-disable;
-               };
-       };
-
-       spi_0_pins: spi_0_pinmux {
-               pin {
-                       function = "blsp_spi0";
-                       pins = "gpio55", "gpio56", "gpio57";
-                       drive-strength = <2>;
-                       bias-disable;
-               };
-               pin_cs {
-                       function = "gpio";
-                       pins = "gpio54";
-                       drive-strength = <2>;
-                       bias-disable;
-                       output-high;
-               };
-       };
-};
-
-&blsp_dma {
-       status = "okay";
-};
-
-&blsp1_spi1 {
-       status = "okay";
-
-       pinctrl-0 = <&spi_0_pins>;
-       pinctrl-names = "default";
-       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
-
-       flash@0 {
-               reg = <0>;
-               compatible = "jedec,spi-nor";
-               spi-max-frequency = <40000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "Qualcomm";
-                               reg = <0x0 0x80000>;
-                               read-only;
-                       };
-
-                       partition@80000 {
-                               compatible = "mikrotik,routerboot-partitions";
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               label = "RouterBoot";
-                               reg = <0x80000 0x80000>;
-
-                               hard_config {
-                                       read-only;
-                                       size = <0x2000>;
-                               };
-
-                               dtb_config {
-                                       read-only;
-                               };
-
-                               soft_config {
-                               };
-                       };
-
-                       partition@100000 {
-                               compatible = "mikrotik,minor";
-                               label = "firmware";
-                               reg = <0x100000 0xf00000>;
-                       };
-               };
-       };
-};
-
-&blsp1_uart1 {
-       status = "okay";
-
-       pinctrl-0 = <&serial_pins>;
-       pinctrl-names = "default";
-};
-
-&cryptobam {
-       status = "okay";
-};
-
-&crypto {
-       status = "okay";
-};
-
-&watchdog {
-       status = "okay";
-};
-
-&mdio {
-       status = "okay";
-};
-
-&gmac {
-       status = "okay";
-};
-
-&switch {
-       status = "okay";
-};
-
-&swport4 {
-       status = "okay";
-       label = "sw-eth2";
-};
-
-&swport5 {
-       status = "okay";
-       label = "sw-eth1";
-};
-
-&wifi0 {
-       status = "okay";
-
-       qcom,ath10k-calibration-variant = "MikroTik-wAP-ac";
-};
-
-&wifi1 {
-       status = "okay";
-
-       qcom,ath10k-calibration-variant = "MikroTik-wAP-ac";
 };
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dtsi b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-ac.dtsi
new file mode 100644 (file)
index 0000000..777f46e
--- /dev/null
@@ -0,0 +1,215 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/* Copyright (c) 2020, Robert Marko <robimarko@gmail.com> */
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       memory {
+               device_type = "memory";
+               reg = <0x80000000 0x08000000>;
+       };
+
+       chosen {
+               stdout-path = "serial0:115200n8";
+       };
+
+       aliases {
+               led-boot = &led_user;
+               led-failsafe = &led_user;
+               led-running = &led_user;
+               led-upgrade = &led_user;
+       };
+
+       soc {
+               counter@4a1000 {
+                       compatible = "qcom,qca-gcnt";
+                       reg = <0x4a1000 0x4>;
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "blue:power";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
+                       default-state = "keep";
+               };
+
+               led_user: user {
+                       label = "green:user";
+                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
+                       panic-indicator;
+               };
+       };
+};
+
+&prng {
+       status = "okay";
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pin {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       drive-strength = <2>;
+                       bias-disable;
+               };
+               pin_cs {
+                       function = "gpio";
+                       pins = "gpio54";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       status = "okay";
+
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               reg = <0>;
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "Qualcomm";
+                               reg = <0x0 0x80000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               compatible = "mikrotik,routerboot-partitions";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               label = "RouterBoot";
+                               reg = <0x80000 0x80000>;
+
+                               hard_config {
+                                       read-only;
+                                       size = <0x2000>;
+                               };
+
+                               dtb_config {
+                                       read-only;
+                               };
+
+                               soft_config {
+                               };
+                       };
+
+                       partition@100000 {
+                               compatible = "mikrotik,minor";
+                               label = "firmware";
+                               reg = <0x100000 0xf00000>;
+                       };
+               };
+       };
+};
+
+&blsp1_uart1 {
+       status = "okay";
+
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&crypto {
+       status = "okay";
+};
+
+&watchdog {
+       status = "okay";
+};
+
+&mdio {
+       status = "okay";
+};
+
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport4 {
+       status = "okay";
+       label = "sw-eth2";
+};
+
+&swport5 {
+       status = "okay";
+       label = "sw-eth1";
+};
+
+&wifi0 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "MikroTik-wAP-ac";
+};
+
+&wifi1 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "MikroTik-wAP-ac";
+};
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-r-ac.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wap-r-ac.dts
new file mode 100644 (file)
index 0000000..e7f28f2
--- /dev/null
@@ -0,0 +1,45 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/* Copyright (c) 2022, Alexander Couzens <lynxis@fe80.eu> */
+
+#include "qcom-ipq4018-wap-ac.dtsi"
+
+/ {
+       model = "MikroTik wAP R ac";
+       compatible = "mikrotik,wap-r-ac";
+
+       soc {
+               tcsr@194b000 {
+                       /* select hostmode */
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+                       status = "okay";
+               };
+
+               usb3@8af8800 {
+                       status = "okay";
+
+                       dwc3@8a00000 {
+                               phys = <&usb3_hs_phy>;
+                               phy-names = "usb2-phy";
+                       };
+               };
+       };
+};
+
+&tlmm {
+       enable-usb-power {
+               gpio-hog;
+               gpios = <2 GPIO_ACTIVE_HIGH>;
+               output-high;
+               line-name = "enable USB power";
+       };
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb3 {
+       status = "okay";
+};
index 3eacedd9d8d74834605a1e8daaaaa699b761b1bd..f0e1f1aad34d92f2bf04e38e692ddf0725473fe8 100644 (file)
@@ -78,3 +78,23 @@ define Device/mikrotik_wap-ac
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += mikrotik_wap-ac
+
+define Device/mikrotik_wap-r-ac
+       $(call Device/mikrotik_wap-ac)
+       DEVICE_MODEL := wAP R ac
+       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi \
+               kmod-usb-acm kmod-usb-net-rndis
+       DEVICE_DTS := qcom-ipq4018-wap-r-ac
+endef
+TARGET_DEVICES += mikrotik_wap-r-ac
+
+define Device/mikrotik_wap-ac-lte
+       $(call Device/mikrotik_wap-ac)
+       DEVICE_MODEL := wAP ac LTE
+       DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi \
+               kmod-usb-acm kmod-usb-net-rndis
+       DEVICE_DTS := qcom-ipq4018-wap-ac-lte
+       DEVICE_ALT0_VENDOR = Mikrotik
+       DEVICE_ALT0_MODEL := wAP ac LTE6
+endef
+TARGET_DEVICES += mikrotik_wap-ac-lte