tools/libtool: refresh patches
authorMichael Pratt <mcpratt@pm.me>
Thu, 9 Mar 2023 13:29:38 +0000 (08:29 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Mar 2023 21:53:41 +0000 (22:53 +0100)
Preparation for bumping libtool several versions at once,
which includes some complex changes to patches.

Remove an empty line change from a patch.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/libtool/patches/000-relocatable.patch
tools/libtool/patches/120-strip-unsafe-dirs-for-relinking.patch
tools/libtool/patches/160-passthrough-ssp.patch

index 996e6445be9cbf54828738f0e32825487cd4ac91..a5fa04069663c9dc39a37c1f0fb29944620e948f 100644 (file)
    configure_ac=configure.in
 --- a/libltdl/m4/libtool.m4
 +++ b/libltdl/m4/libtool.m4
-@@ -907,9 +907,8 @@ dnl AC_DEFUN([AC_LIBTOOL_RC], [])
- # ----------------
- m4_defun([_LT_TAG_COMPILER],
+@@ -909,7 +909,7 @@ m4_defun([_LT_TAG_COMPILER],
  [AC_REQUIRE([AC_PROG_CC])dnl
--
  _LT_DECL([LTCC], [CC], [1], [A C compiler])dnl
 -_LT_DECL([LTCFLAGS], [CFLAGS], [1], [LTCC compiler flags])dnl
 +_LT_DECL([LTCFLAGS], [CFLAGS], ["-O2 -I\${STAGING_DIR_HOST:-$STAGING_DIR_HOST}/include"], [LTCC compiler flags])dnl
  _LT_TAGDECL([CC], [compiler], [1], [A language specific compiler])dnl
  _LT_TAGDECL([with_gcc], [GCC], [0], [Is the compiler the GNU compiler?])dnl
  
-@@ -7660,9 +7659,9 @@ m4_defun([_LT_DECL_EGREP],
+@@ -7660,9 +7660,9 @@ m4_defun([_LT_DECL_EGREP],
  [AC_REQUIRE([AC_PROG_EGREP])dnl
  AC_REQUIRE([AC_PROG_FGREP])dnl
  test -z "$GREP" && GREP=grep
  dnl Non-bleeding-edge autoconf doesn't subst GREP, so do it here too
  AC_SUBST([GREP])
  ])
-@@ -7695,9 +7694,8 @@ AC_SUBST([DLLTOOL])
+@@ -7695,9 +7695,8 @@ AC_SUBST([DLLTOOL])
  # as few characters as possible.  Prefer GNU sed if found.
  m4_defun([_LT_DECL_SED],
  [AC_PROG_SED
index 8840ee056998c5d7459b5c8f0badde98ab7530ff..d5729e68ac6f0a1a9e8d11db83d59a16da7e7655 100644 (file)
@@ -1,6 +1,6 @@
 --- a/libltdl/config/ltmain.m4sh
 +++ b/libltdl/config/ltmain.m4sh
-@@ -2183,6 +2183,9 @@ func_mode_install ()
+@@ -2186,6 +2186,9 @@ func_mode_install ()
            relink_command=`$ECHO "$relink_command" | $SED "s%@inst_prefix_dir@%%"`
          fi
  
index da44c614e3d16e804ba9ce03c1b06c1ae6fc0384..2f6838cb85253d7a593ef618957a09777ccb2a29 100644 (file)
@@ -1,7 +1,6 @@
-diff -ur libtool-2.4.orig/libltdl/config/ltmain.m4sh libtool-2.4/libltdl/config/ltmain.m4sh
---- libtool-2.4.orig/libltdl/config/ltmain.m4sh        2015-06-18 10:46:15.499996979 +0200
-+++ libtool-2.4/libltdl/config/ltmain.m4sh     2015-06-18 10:48:24.686882213 +0200
-@@ -5076,7 +5076,7 @@
+--- a/libltdl/config/ltmain.m4sh
++++ b/libltdl/config/ltmain.m4sh
+@@ -5076,7 +5076,7 @@ func_mode_link ()
        # -O*, -flto*, -fwhopr*, -fuse-linker-plugin GCC link-time optimization
        -64|-mips[0-9]|-r[0-9][0-9]*|-xarch=*|-xtarget=*|+DA*|+DD*|-q*|-m*| \
        -t[45]*|-txscale*|-p|-pg|--coverage|-fprofile-*|-F*|@*|-tp=*|--sysroot=*| \